POJ1328 贪心

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 76872 Accepted: 17220

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题意:一条海岸线,海岸线半边是海,半边是大陆,但在海上有许多岛,要求在海岸线上建立雷达,以至于可以检测到所有岛。给出所有岛的坐标和雷达检测的半径,求出最少用多少个雷达可以检测到所有岛。

思路;最开始的思路是按照岛的横坐标排序,然后从左边第一个岛依次遍历,求出可以检测到这个岛的雷达能检测到的所有岛,然后把这些岛标记为已检测,直到最后一个岛,看用了几个雷达,但这种思路超时了,也不太好优化,所以放弃了。后来一种思路是转化为相交区间问题,因为可以检测到的每个岛的雷达都会有一个区间范围,如果下一个岛的雷达区间与上一个岛有重合,则不用在加雷达,反之则再加一个雷达。


AC代码:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
struct node
{
    double l;
    double r;
}a[1005];
bool cmp(node a,node b)
{
    return a.l<b.l;
}
int main()
{
    //freopen("D://in.txt","r",stdin);
    int num,n,d,y,T=1;
    double dist,x;
    while(~scanf("%d %d",&n,&d))
    {
        if(n==0&&d==0)
            break;
        bool flag=false;
        if(d<=0)
            flag=true;
        for(int i=1;i<=n;i++)
        {
            scanf("%lf %d",&x,&y);
            if(abs(y)<=d)
            {
                dist=sqrt(double(d*d-y*y));
                a[i].r=x+dist;
                a[i].l=x-dist;
            }
            else
                flag=true;
        }
        if(flag)
        {
            printf("Case %d: -1\n",T++);
            continue;
        }
        sort(a+1,a+n+1,cmp);
        x=a[1].r;
        num=1;
        for(int i=2;i<=n;i++)
        {
            if(a[i].l>x)
            {
                num++;
                x=a[i].r;
            }
            else
                x=min(a[i].r,x);
        }
        printf("Case %d: %d\n",T++,num);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值