UVA-11827 Maximum GCD(辗转相除法求GCD)

Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible pair of these integers.

Input

The first line of input is an integer N (1 < N < 100) that determines the number of test cases.

The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive integers that you have to find the maximum of GCD.

Output

For each test case show the maximum GCD of every possible pair.

Sample Input

3

10 20 30 40

7 5 12

125 15 25

Sample Output

20

1

25

题目意思是给你若干个数字(数字个数不确定),要求你求出任意两个数的最大公约数的最大值。 

对于数字的分解可以有两种方法:

        1:对于每组数据,通过循环,将一个个数字分解出来,并存入数组

        2:将每组数据以字符串形式放入字符串流中并通过istringstream将字符串类型转化为int类型

对于最大公因数的求解 由于数据量不大,直接暴力循环判断即可

法一:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<cmath>

using namespace std;

int arr[1000];

int GCD(int a, int b) {
    if(a < b) {
        a = a + b;
        b = a - b;
        a = a - b;
    }
    int c = a % b;
    while(c) {
        a = b;
        b = c;
        c = a % b;
    }
    return b;
}

int main() {
    int n,res,m,Len,tmp;
    char str[10000];
    scanf("%d",&n);
    getchar();
    while(n--){
        m = 0;
        gets(str);
        Len = strlen(str);
        tmp = 0;
        for(int i = 0;i < Len;i++) {
            tmp = 0;
            while(str[i] != ' ' && str[i] != '\0') {
                tmp = tmp * 10 + str[i++] - '0';
            }
            arr[m++] = tmp;
        }
        res = 0;
        for(int i = 0;i < m;i++)
            for(int j = i + 1;j < m;j++)
                res = max(res,GCD(arr[i],arr[j]));
        printf("%d\n",res);
    }
    return 0;
}

法二:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<sstream>
#include<string>

using namespace std;

int arr[1000];

int GCD(int a, int b) {
    if(a < b) {
        a = a + b;
        b = a - b;
        a = a - b;
    }
    int c = a % b;
    while(c) {
        a = b;
        b = c;
        c = a % b;
    }
    return b;
}

int main() {
    int n,res,m,Len,tmp;
    char str[10000];
    scanf("%d",&n);
    getchar();
    while(n--){
        m = 0;
        gets(str);              //读入一行
        istringstream istr(str);//把str中的字符串存入字符串流中
        int tmp;
        while(istr >> tmp) {    //以空格为界,把istringstream中的数据取出,并将其转化为int类型
            arr[m++] = tmp;
        }
        res = 0;
        for(int i = 0;i < m;i++)
            for(int j = i + 1;j < m;j++)
                res = max(res,GCD(arr[i],arr[j]));
        printf("%d\n",res);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值