HDU-2674 N!Again

WhereIsHeroFrom:             Zty, what are you doing ? 
Zty:                                     I want to calculate N!...... 
WhereIsHeroFrom:             So easy! How big N is ? 
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000… 
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao? 
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009 


Hint : 0! = 1, N! = N*(N-1)! 

Input

Each line will contain one integer N(0 <= N<=10^9). Process to end of file. 

Output

For each case, output N! mod 2009 

Sample Input

4 
5

Sample Output

24
120

题目意思是n的阶乘对2009进行取模

首先n的范围很大,暴力求n!并取模很大会超时。但通过观察我们可以发现2009可以被7、41、49整除,那么若n大于等于49之后无论n为何值,n! % 2009必为0(41*49=2009,当n大于等于49,就相当于2009乘以一个数与2009取模,得到的答案必为0),而对于n小于49,只需暴力循环求n!即可(注意,在求n!的过程中要对2009进行取模)

#include<iostream>

using namespace std;

const int mod = 2009;

int main() {
    int n, tmp;
    while(cin >> n) {
        tmp = 1;
        if(n >= 49) {
            cout << "0" << endl;
            continue;
        }
        for(int i = 2;i <= n;i++) {
            tmp = (tmp * i) % mod;
        }
        cout << tmp << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值