HDU-4709 Herding

Little John is herding his father's cattles. As a lazy boy, he cannot tolerate chasing the cattles all the time to avoid unnecessary omission. Luckily, he notice that there were N trees in the meadow numbered from 1 to N, and calculated their cartesian coordinates (Xi, Yi). To herding his cattles safely, the easiest way is to connect some of the trees (with different numbers, of course) with fences, and the close region they formed would be herding area. Little John wants the area of this region to be as small as possible, and it could not be zero, of course.

Input

The first line contains the number of test cases T( T<=25 ). Following lines are the scenarios of each test case. 
The first line of each test case contains one integer N( 1<=N<=100 ). The following N lines describe the coordinates of the trees. Each of these lines will contain two float numbers Xi and Yi( -1000<=Xi, Yi<=1000 ) representing the coordinates of the corresponding tree. The coordinates of the trees will not coincide with each other.

Output

For each test case, please output one number rounded to 2 digits after the decimal point representing the area of the smallest region. Or output "Impossible"(without quotations), if it do not exists such a region.

Sample Input

1
4
-1.00 0.00
0.00 -3.00
2.00 0.00
2.00 2.00

Sample Output

2.00

题目意思:

       给你n个坐标,要你求出用由这些点构成的最小的面积(点可以不全用上)

解题思路:

       想要得到面积最小的图形,明显只可能是三角形,而且本题数据范围小,直接暴力循环求解即可。需要注意的是这题需要用叉乘来求三角形面积。我们知道\underset{a}{\rightarrow}\times\underset{b}{\rightarrow}的几何意义是由向量a和向量b组成的平行四边形的面积,因此,我们可以通过\underset{a}{\rightarrow}\times\underset{b}{\rightarrow}/ 2求出一个三角形的面积

#include<iostream>
#include<cmath>
#include<cstdio>

using namespace std;

const double Inf = 1e9;

struct Point{
    double x, y;
};

double getArea(Point a, Point b, Point c) {
    return fabs((a.x - b.x) * (a.y - c.y) - (a.x - c.x) * (a.y - b.y)) / 2;
}

int main() {
    int t, n;
    double minArea, tmp;
    Point P[110];
    scanf("%d",&t);
    while(t--) {
        minArea = Inf;
        scanf("%d",&n);
        for(int i = 0;i < n;i++) {
            scanf("%lf%lf",&P[i].x,&P[i].y);
        }
        for(int i = 0;i < n;i++) {
            for(int j = i + 1;j < n;j++) {
                for(int k = j + 1;k < n;k++) {
                    tmp = getArea(P[i],P[j],P[k]);
                    if(tmp != 0 && tmp < minArea){
                        minArea = tmp;
                    }
                }
            }
        }
        if(minArea < Inf) {
            printf("%.2f\n",minArea);
        }
        else{
            printf("Impossible\n");
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值