Conscription 征兵

12 篇文章 0 订阅
 Conscription
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223
 
    
其实可以把有关系的男女看成是一棵树,用并查集来维护森林,因为可能存在多棵树,利用sort排序,每次都选最大的边,知道把所有的边都遍历一边,这个题一开始自己没法处理的是,发现给出的点与点可能相同,像1-1-10,直接套用并查集的话不行,所以在这里做一个小处理,每个y+n,其实也就是把x,y放到一个列表里
 
    
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define inf 0x3f3f3f3f
#define maxn 10001
#define maxm 50002
using namespace std;     
int n,m,r;
int f[maxn*2];  //因为是两个点,每个点的取值范围都是maxn
struct node{
	int x,y,d;
};
node edge[maxm];
int getf(int i)
{
	if(i==f[i])
		return i;
	return f[i]=getf(f[i]);
}
int merge(int a, int b)
{
	int i=getf(a);
	int j=getf(b);
	if(i!=j)
	{
		f[j]=i;
		return 1;
	}
	return 0;
}

int cmp(node a, node b)
{
	return a.d>b.d;
}
int main()
{
	int t,cnt=0;
	long long sum;
	scanf("%d",&t);
	while(t--)
	{
		sum=0,cnt=0;
		scanf("%d%d%d",&n,&m,&r);
		for(int i=0;i<r;i++)
		{
			int temp;
			scanf("%d%d%d",&edge[i].x,&temp,&edge[i].d);
			edge[i].y=temp+n;  //处理y点,把y点放到x点的后面
		}
		sort(edge,edge+r,cmp);
		for(int i=0;i<n+m;i++) //并查集的初始化,一定记得初始化
			f[i]=i;
		for(int i=0;i<r;i++)
		{
			if(merge(edge[i].x,edge[i].y))
			{
				sum+=edge[i].d;
			}
		}
	
		printf("%lld\n",10000*(n+m)-sum);
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值