POJ 1703 Find them, Catch them 种类并查集

12 篇文章 0 订阅
Find them, Catch them
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%lld & %llu

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.

In the same gang.

这个题有三种可能,用普通的并查集来进行判断两个数是否属于同一gang就不行了,所以需要对并查集进行改变

把选择为D的两个数进行并查集的合并,确定关系为他俩之间要么在同一个gang里面,要么不在,如果两个数不在同一个并查集合并的集合里面,就判定这两个数为不确定状态

AC代码:

//#include<bits/stdc++.h>    
#include<iostream>      
#include<cstdio>      
#include<cstdlib>      
#include<cstring>      
#include<string>      
#include<queue>      
#include<algorithm>      
#include<map>      
#include<iomanip>   
#define inf 0x3f3f3f3f      
#define maxn 100005
#define maxm 10000
using namespace std;

int n,m;
int f[maxn],rel[maxn];

int getf(int a) {
	if(a==f[a])
		return a;
	else {
		int fa = f[a];
		f[a] = getf(f[a]);
		rel[a] = (rel[fa] + rel[a]) % 2; //每次都利用子节点与父节点的关系,父节点与爷爷节点的关系,判断 
		return f[a];                     // 子节点与爷爷节点的关系,该式子其实一个异或的关系 
	}
}

void merge(int a, int b) {
	int fa = getf(a);
	int fb = getf(b);
	f[fb] = fa;
	rel[fb] = (rel[a] + rel[b] + 1) % 2; //每次merge都对原来的根节点进行修改,该式子包含了所有的情况 
}

int main()
{
	int t, a, b;
	char c[2];
	scanf("%d",&t);
	while(t--) {
		scanf("%d%d",&n,&m);
		for(int i = 1;i <= n;++i) {
			f[i] = i;
			rel[i] = 0;
		}
		for(int i = 0;i < m;++i) {
			scanf("%s%d%d",c,&a,&b);
			if(c[0] == 'D') 
				merge(a, b);
			else {
				if(getf(a) != getf(b))
					printf("Not sure yet.\n");
				else {
					if(rel[a] == rel[b])
						printf("In the same gang.\n");
					else printf("In different gangs.\n");
				}
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值