PAT A1009 roduct of Polynomials(25)[多项式相乘, 高精度]

PAT A1009 Product of Polynomials(25)

This time, you are supposed to find A × B A×B A×B where A A A and B B B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N 1 a N 1 a N 2 . . . a N K K \quad N_1 a_{N_1} a_{N_2} ... a_{N_K} KN1aN1aN2...aNK

where K is the number of nonzero terms in the polynomial, N i N_i Ni and a N i a_{N_i} aNi ( i = 1 , 2 , ⋯ , K i=1,2,⋯,K i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 0 , 0 ≤ N K ⋯ ≤ N 2 ≤ N 1 ≤ 1000 1 \leq K \leq 0,0 \leq N_K \cdots \leq N_2 \leq N_1 \leq 1000 1K00NKN2N11000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题意

两个多项式相乘,输出结果的项数系数指数

思路1

  1. 使用两个数组分别存储每个多项式项的系数
  2. 两重循环遍历所有情况,多项式 A中的一项与多项式 B 中的一项 a i x n a_ix^n aixn b j x m b_jx^m bjxm 的乘积为 a i b j x n + m a_ib_jx^{n+m} aibjxn+m

时间复杂度为 O ( N 2 ) O(N^2) O(N2)

代码1

#include <iostream>
using namespace std;
const int N = 1010;
double a[N], b[N], c[N * 2];  // double 数组
int main()
{
    int k, x;
    double y;
    cin >> k;
    for(int i = 0; i < k; i++)
    {
        cin >> x >> y;
        a[x] = y;
    }
    
    cin >> k;
    for(int i = 0; i < k; i++)
    {
        cin >> x >> y;
        b[x] = y;
    }
    
    for(int i = 0; i < N; i++)
    {
        for(int j = 0; j < N; j++)
        {
            c[i + j] += a[i] * b[j];
        }
    }
    int cnt = 0;
    for(int i = 0; i < 2 * N; i++)
        if(c[i]) 
            cnt++;
    cout << cnt;
    for(int i = 2 * N - 1; i >= 0; i--)
    {
        if(c[i])
            printf(" %d %.1f", i, c[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值