POJ-Frogger(最小生成树)

Frogger

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题目链接:

http://poj.org/problem?id=2253

提议描述:

给你n个点,其中1号点与2号点各有一只青蛙,青蛙1想跳到青蛙2上,但是呢,跳的距离有限,求跳到2号青蛙位置,所经过的路段的最大值,该值最小是多少。

解题思路:

我用的是克鲁斯卡尔算法,把各个点之间的距离存起来,自己到自己的距离定义为无穷大,然后把各个点之间的距离排个序,直到1号点和2号点有共同祖先,把该路段的距离输出,即为最小距离。

程序代码:

克鲁斯卡尔算法:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define inf 99999999

struct data{
	int x;
	int y;
	int u;
	int v;
	double w;
}e[40010];

int f[210];

double F(data a,data b);
int cmp(data a,data b);
int getf(int u);
int merge(int u,int v);

int main()
{
	int n,i,j,t,count=1;
	double maxn;
	while(scanf("%d",&n),n!=0)
	{
		t=1;
		for(i=1;i<=n;i++)
			scanf("%d%d",&e[i].x,&e[i].y);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
				{
					e[t].u=i;
					e[t].v=j;
					e[t].w=inf;
				}	
				else
				{
					e[t].u=i;
					e[t].v=j;
					e[t].w=F(e[i],e[j]);
				}
				t++;	
			}
		sort(e+1,e+1+n*n,cmp);
		for(i=1;i<=n;i++)
			f[i]=i;
		for(i=1;i<=n*n;i++)
		{
			merge(e[i].u,e[i].v);
			if(getf(1)==getf(2))
			{
				maxn=e[i].w;
				break;
			}
		}		
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",count++,maxn);			
	}
	return 0;
} 

double F(data a,data b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)*1.0+(a.y-b.y)*(a.y-b.y)*1.0);
}

int cmp(data a,data b)
{
	return a.w<b.w;
}

int getf(int u)
{
	if(u==f[u])
		return u;
	f[u]=getf(f[u]);
	return f[u];
}

int merge(int u,int v)
{
	u=getf(u);
	v=getf(v);
	if(u!=v)
	{
		f[v]=u;
		return 1;
	}
	return 0;
}

弗洛伊德算法:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 99999999

struct data{
	int x;
	int y;
}a[210];

double e[210][210],dis[210];
bool book[210];

double F(data a,data b);

int n;

int main()
{
	int i,j,k,count=1;
	double maxn;
	while(scanf("%d",&n),n!=0)
	{
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i].x,&a[i].y);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					e[i][j]=inf;
				else
					e[i][j]=F(a[i],a[j]);
			}
		for(k=1;k<=n;k++)
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
				{
					if(e[i][j]>max(e[i][k],e[k][j]))
						e[i][j]=max(e[i][k],e[j][k]);
				}	
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",count++,e[1][2]);
	}	
	return 0;
}

double F(data a,data b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)*1.0+(a.y-b.y)*(a.y-b.y)*1.0);
}

prim算法:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 99999999

struct data{
	int x;
	int y;
}a[210];

double e[210][210],dis[210];
bool book[210];

double F(data a,data b);
double prime();

int n;

int main()
{
	int i,j,k,count=1;
	double maxn;
	while(scanf("%d",&n),n!=0)
	{
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i].x,&a[i].y);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					e[i][j]=inf;
				else
					e[i][j]=F(a[i],a[j]);
			}
				
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",count++,prime());
	}	
	return 0;
}

double F(data a,data b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)*1.0+(a.y-b.y)*(a.y-b.y)*1.0);
}

double prime()
{
	int i,k,mi,u,maxn;
	for(i=1;i<=n;i++)
		dis[i]=e[1][i];
	memset(book,0,sizeof(book));
	book[1]=1;
	maxn=-1;
	for(k=1;k<n;k++)
	{
		mi=inf;
		for(i=1;i<=n;i++)
		{
			if(book[i]==0&&dis[i]<mi)
			{
				u=i;
				mi=dis[i];
			}
		}
		book[u]=1;
		for(i=1;i<=n;i++)
		{
			if(book[i]==0&&e[u][i]<dis[i])
			{
				dis[i]=min(dis[i],max(dis[u],e[u][i]));
			} 
				
		}
	}
	return dis[2];
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

贺志营

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值