HDU 4027 Can you answer these queries?【线段树】

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 21008    Accepted Submission(s): 4980


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6
#include<bits/stdc++.h>
using namespace std;
#define mms(x) memset(x, 0, sizeof x)
#define ll long long
#define MAX 1000005
#define lson rt << 1, l, mid
#define rson rt << 1 | 1, mid + 1, r
ll tree[MAX << 2], maxn[MAX << 2];
int n, m, Case = 0;
void PushUp(int rt)
{
    tree[rt] = tree[rt << 1] + tree[rt << 1 | 1];
    maxn[rt] = max(maxn[rt << 1], maxn[rt << 1 | 1]);
}
void BuildTree(int rt, int l, int r)
{
    if(l == r)
    {
        cin >> tree[rt];
        maxn[rt] = tree[rt];
        return;
    }
    int mid = (l + r) >> 1;
    BuildTree(lson);
    BuildTree(rson);
    PushUp(rt);
}
ll Query(int rt, int l, int r, int x, int y)
{
    if(x <= l && r <= y)
        return tree[rt];
    int mid = (l + r) >> 1;
    ll ans = 0;
    if(x <= mid)
        ans += Query(lson, x, y);
    if(mid < y)
        ans += Query(rson, x, y);
    return ans;
}
void Update(int rt, int l, int r, int x, int y)
{
    if(maxn[rt] <= 1)
        return;
    if(l == r)
    {
        maxn[rt] = tree[rt] = sqrt(tree[rt]);
        return;
    }
    int mid = (l + r) >> 1;
    if(x <= mid)
        Update(lson, x, y);
    if(mid < y)
        Update(rson, x, y);
    PushUp(rt);
}
void init()
{
    mms(tree);
    mms(maxn);
    BuildTree(1, 1, n);
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin >> n)
    {
        init();
        cin >> m;
        cout << "Case #" << ++Case << ":" << endl;
        for(int i = 0, x, y, z; i < m; i++)
        {
            cin >> x >> y >> z;
            if(y > z)///这题傻逼就傻逼在这了
                swap(y, z);
            if(x == 0)
                Update(1, 1, n, y, z);
            else
                cout << Query(1, 1, n, y, z) << endl;
        }
        cout << endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值