Can you answer these queries?(根号线段树)

Can you answer these queries?(根号线段树)

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output
Case #1:
19
7
6

题意: 0:区间每个数开平方取整,1:求区间和

思路: 如果在大区间(区间不止一个数)开平方,会造成误差,所以必须小区间开平方,然后一直改变到根节点,这样会很费时,所以需要剪枝,当数为1时,开不开都一样,所以就没有开的必要

AC代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
#define ll long long
#define lef st,mid,rt<<1
#define rig mid+1,en,rt<<1|1
#include<algorithm>
using namespace std;
const int N=1e6+100;
ll a[N],t[N],n,m,tt,x,y,ans;
void up(ll rt)
{
	t[rt]=t[rt<<1]+t[rt<<1|1];
}
void build(ll st,ll en,ll rt)
{
	if(st==en)
	t[rt]=a[en];
	else
	{
		ll mid=(st+en)>>1;
		build(lef);
		build(rig);
		up(rt); 
	}
}
void update(ll st,ll en,ll rt)
{
	if(en-st+1==t[rt])//前者为区间数的个数,如果区间中都为1,根节点的值=区间个数,1开方还是1,故不需再次操作,直接返回,相当于剪枝
	return ;
	if(st==en)//小区间开方
	t[rt]=(ll)sqrt(t[rt]*1.0);
	else
	{
		ll mid=(st+en)>>1;
		if(x<=mid)
		update(lef);
		if(mid<y)
		update(rig);
		up(rt);
	}	
}
ll query(ll st,ll en,ll rt)
{
	if(en-st+1==t[rt])
	return ans+=(min(en,y)-max(st,x)+1);//返回较小区间的值
	if(x<=st&&en<=y)
	return ans+=t[rt];
	else
	{
		ll mid=(st+en)>>1;
		if(x<=mid)
		 ans=query(lef);
		if(y>mid)
		 ans=query(rig);
		return ans;
	}
}
int main()
{
	ll i,j,k=1;
	while(~scanf("%lld",&n))
	{
		memset(a,0,sizeof(a));
		memset(t,0,sizeof(t));
		for(i=1;i<=n;i++)
		scanf("%lld",&a[i]);
		build(1,n,1);
		scanf("%lld",&m);
		printf("Case #%d:\n",k++);
		while(m--)
		{
			scanf("%lld%lld%lld",&tt,&x,&y);
			if(x>y)//这是一个坑,要注意
			swap(x,y);
			ans=0;
			if(tt==0)
			update(1,n,1);
			else
			printf("%lld\n",query(1,n,1));
		}
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值