POJ3259 Wormholes SPFA负权回路判断

题目要我们求是否存在一条路,FJ重新回到起点之后时间回到了过去,就是让我们判断在图中是否存在负权回路。
我用了SPFA,当一个点入队超过n次时,可以判断图中存在负权回路。
注意图中的前m条路是双向的,注意处理
后面的w条虫洞是单向的。
Wormholes

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 20408

 

Accepted: 7257

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N,M (1 ≤M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps toF (1 ≤F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
 
#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
#include<algorithm>

using namespace std;

#define MAXN 550
#define INF  0xFFFFFF
struct node
{
	int to;
	int dis;
};

bool in[MAXN];
int  counts[MAXN],dis[MAXN],n,m,w;
vector<node> g[MAXN];

bool spfa(int s)
{
	queue<int> q;
	for(int i=1;i<=n;i++)
	{
		dis[i]=INF;
		counts[i]=0;
		in[i]=false;
	}
	dis[s]=0;
	counts[s]=1;
	in[s]=true;
	q.push(s);
	while(!q.empty())
	{
		int tag=q.front();
		q.pop();
		in[tag]=false;
		for(int i=0;i<g[tag].size();i++)
		{
			int j=g[tag][i].to;
			if(g[tag][i].dis+dis[tag]<dis[j])
			{
				dis[j]=g[tag][i].dis+dis[tag];
				if(!in[j])
				{
					in[j]=true;
					counts[j]++;
					if(counts[j]>=n)
						return false;
					q.push(j);
				}
			}
		}	
	}
	return true;
}

void init()
{
	cin>>n>>m>>w;
	int x,y,d;
	node temp;
	for(int i=0;i<=n;i++)
		g[i].clear();
	for(int i=1;i<=m;i++)
	{
		cin>>x>>y>>d;
		temp.to=y;
		temp.dis=d;
		g[x].push_back(temp);
		temp.to=x;
		g[y].push_back(temp);
	}
	for(int i=1;i<=w;i++)
	{
		cin>>x>>y>>d;
		temp.to=y;
		temp.dis=-d;
		g[x].push_back(temp);
	}
	
}

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		init();
		if(spfa(1))
			cout<<"NO"<<endl;
		else
			cout<<"YES"<<endl;
		
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值