HDU - 6197 array array array (最长上升子序列)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=6197

One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum. 
Kiddo: "I have an array AA and a number kk, if you can choose exactly kk elements from AA and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say AA is a magic array. Now I want you to tell me whether AA is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him? 

Input

The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers nn and kk in one line, then one line with nnintegers: A1,A2…AnA1,A2…An. 
1≤T≤201≤T≤20 
1≤n≤1051≤n≤105 
0≤k≤n0≤k≤n 
1≤Ai≤1051≤Ai≤105 

Output

For each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes). 

Sample Input

3
4 1
1 4 3 7
5 2
4 1 3 1 2
6 1
1 4 3 5 4 6

Sample Output

A is a magic array.
A is a magic array.
A is not a magic array.

题意:(原题意应该有问题)

给出数组长度n和k,如果在数组中去除k个数能够使数组变为递增序或递减序那么原数组就是一个magic array,反之不是。

  思路:

  求出最长上升子序列L,则剩下的n-L如果小于等于k,那么就满足条件。

#include <bits/stdc++.h>
using namespace std;
const int maxn=1e5+10;
int a[maxn],b[maxn];
int y[maxn];

int serch(int num,int low,int high)
{
    int mid;
    while(low<=high){
        mid=(low+high)/2;
        if(num>=b[mid]) low=mid+1;
        else high=mid-1;
    }
    return low;
}
int dp(int n)
{
    int i,len,pos;
    b[1]=a[1];
    len=1;
    for(int i=2;i<=n;++i){
        if(a[i]>=b[len]){
            len=len+1;
            b[len]=a[i];
        }
        else{
            pos=serch(a[i],1,len);
            b[pos]=a[i];
        }
    }
    return len;
}

int main()
{
    int t,n,k;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&k);
        int x;
        for(int i=1;i<=n;++i){
            scanf("%d",&a[i]);
            y[n-i+1]=a[i];
        }
        bool flag=0;
        memset(b,0,sizeof b);
        if(n-dp(n)<=k) flag=1;
        if(flag) {printf("A is a magic array.\n");}
        else printf("A is not a magic array.\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值