hdu 6197 array array array (LIS,最长上升子序列模板题)

array array array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 727    Accepted Submission(s): 421


Problem Description
One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: "I have an array A and a number k , if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him?
 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2An .
1T20
1n105
0kn
1Ai105
 

Output
For each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes).
 

Sample Input
 
 
3 4 1 1 4 3 7 5 2 4 1 3 1 2 6 1 1 4 3 5 4 6
 

Sample Output
 
 
A is a magic array. A is a magic array. A is not a magic array.
 

题意:
给你一个数组,以及n,k。问你在这个数组里任意去掉k个数,能否让该数组变成一个非递增数组或者非递减数组

解析:
非递减数组: a[i]<=a[i+1],例如 1,3,5,7,8 ; 1,1,1,1,1 ; 1,1,2,3,6
非递增数组: a[i]>=a[i+1],例如 7,6,5,4,3,2 ; 1,1,1,1 ; 7,6,5,2,2,1

用动态规划,类似的大神讲解就是求一个最长有序子序列 http://blog.csdn.net/zhangyx_xyz/article/details/50949957

g[len]表示在所有长度为len的情况中,末尾元素最小(即最具有潜力)的a[j]的值
这样一开始g[1]=a[1]
一旦a[i]>g[len],那么g[++len]=a[i]
否则的话在g中找第一个比a[i]小的数g[t],把g[t+1]=a[i](因为原来的g[t+1]>a[i]),这样就可以保持g中每一个值g[i]都是当前长度i下最有潜力的解

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 100010

int n,k,len;
int a[MAXN],g[MAXN];  

int binary_search(int key,int g[],int left,int right)
{
	int mid;
	while(left<right)
	{
		mid=(left+right)>>1;
		if(key>=g[mid]) left=mid+1;
		else right=mid;
	}
	return left;
}

int binary_search1(int key,int g[],int left,int right)
{
	int mid;
	while(left<right)
	{
		mid=(left+right)>>1;
		if(key>g[mid]) right=mid;
		else left=mid+1;
	}
	return right;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int j,flag;
		flag=0;
		scanf("%d%d",&n,&k);
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		//非递减
		g[1]=a[0];
		len=1;
		for(int i=1;i<n;i++)
		{
			if(a[i]>=g[len])
				j=++len;
			else
				j=binary_search(a[i],g,1,len+1);
			g[j]=a[i];
		}	

		if(len+k>=n) flag=1;
		else   //非递增
		{
			g[1]=a[0];
			len=1;
			for(int i=1;i<n;i++)
			{
				if(a[i]<=g[len])
					j=++len;
				else
					j=binary_search1(a[i],g,1,len+1);
				g[j]=a[i];
			}

			if(len+k>=n) flag=1;

		}
		if(flag) printf("A is a magic array.\n");
		else printf("A is not a magic array.\n");


	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值