HDU - 6197(最长单调子序列n(logn))

One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: "I have an array AA and a number kk, if you can choose exactly kk elements from AA and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say AA is a magic array. Now I want you to tell me whether AA is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him?
Input The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers nn and kk in one line, then one line with nn integers: A1,A2AnA1,A2…An.
1T201≤T≤20
1n1051≤n≤105
0kn0≤k≤n
1Ai1051≤Ai≤105
Output For each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes).
Sample Input
3
4 1
1 4 3 7
5 2
4 1 3 1 2
6 1
1 4 3 5 4 6
Sample Output
 

A is a magic array. A is a magic array. A is not a magic array.


题意:删除k个数,判断是否成单调性.

思路:LIS算法题,dp会直接超时。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int a[100010],b[100010],c[100010];
int t,n,m;
int LIS(int *p)
{
    memset(c,0,sizeof(c));
    int l,r,len=0,pan;
    for(int i=1;i<=n;i++)
    {
        r=len,l=0;
        while(l<=r)
        {
            pan=(l+r)/2;
            if(c[pan]<=p[i])
                l=pan+1;
            else
                r=pan-1;
        }
        if(l>len)
            len++;
        c[l]=p[i];
    }
    return len;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d\n",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            b[n-i+1]=a[i];
        }
        int ans=max(LIS(a),LIS(b));
        if(n-ans<=m)
            printf("A is a magic array.\n");
        else
            printf("A is not a magic array.\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值