【PAT】甲级 A1060 Are They Equal (25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10^5 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^100 , and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.12010^3 0.12810^3

代码如下:

#include<iostream>
#include<string>
using namespace std;

int calK(int n,string s){
	int a=s.find('.');
	if(a>0)
		s.erase(s.begin()+a,s.end());
	else if(a==0)
		return 0;
	return s.length();
}
int main(){
	int n;
	string a,b;
	cin>>n>>a>>b;
	string::iterator it1,it2;
	it1=a.begin()+n;
	it2=b.begin()+n;
	bool flag1=false,flag2=false; 
	//删掉先导0 
	while(a[0]=='0'){
		a.erase(a.begin()+a.find('0'));
		flag1=true;
	}
	while(b[0]=='0'){
		b.erase(b.begin()+b.find('0'));
		flag2=true;
	}
//	cout<<"s::"<<a<<" "<<b<<endl;
	int m1=calK(n,a);
	int m2=calK(n,b);
//	cout<<"m::"<<m1<<" "<<m2<<endl;
	//去掉小数点 
	if(a.find('.')>=0&&a.find('.')<a.length())
		a.erase(a.begin()+a.find('.'));
	if(b.find('.')>=0&&b.find('.')<b.length())
		b.erase(b.begin()+b.find('.'));
	//去掉小数点后面的先导0 
	if(flag1){
		while(a[0]=='0'){
			a.erase(a.begin()+a.find('0'));
			m1--; 
		}
	}
	if(a=="") m1=0;
	if(flag2){
		while(b[0]=='0'){
			b.erase(b.begin()+b.find('0'));
			m2--;
		}
	}
	if(b=="") m2=0;
	string s1=a.substr(0,n);
	string s2=b.substr(0,n);
	//长度不足有效位->补零 
	while(s1.length()<n)
		s1+='0';
	while(s2.length()<n)
		s2+='0';
	//输出 
	if(s1==s2&&m1==m2){
		cout<<"YES";
		cout<<" 0."<<s1<<"*10^"<<m1;
	}
	else{
		cout<<"NO";
		cout<<" 0."<<s1<<"*10^"<<m1;
		cout<<" 0."<<s2<<"*10^"<<m2;
	}
	return 0;
} 

需要考虑多种情况,对我来说还是蛮有考验的。
比较典型的需要考虑的问题,如:先导0(000123和123)、全0(0000和0000.00)。再就是精度不够补0的情况。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值