HDU 1495 非常可乐

该博客讨论了一个问题,即在只有两个容量分别为N和M毫升的杯子以及一瓶S毫升的可乐的情况下,如何判断是否能将可乐平分,并找出倒水的最少次数。当S不等于N+M时,无法平分;否则,需要找出达到平分的最小操作数。博客提供了示例输入和输出,并附带了一个C++程序示例。
摘要由CSDN通过智能技术生成

非常可乐

https://vjudge.net/problem/HDU-1495
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3

C++

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

const int MAXN = 100 + 5;
int s, n, m;
bool vis[MAXN][MAXN];

struct node{
	int s, n, m, step;
};

int bfs()
{
	queue<node> q;
	node now, next;
	now.s = s;
	now.n = 0;
	now.m = 0;
	now.step = 0;
	int rest;
	vis[now.n][now.m] = true;
	q.push(now);
	while(!q.empty())
	{
		now = q.front();
		q.pop();
		if(now.n == s / 2 && now.s == s / 2)
			return now.step;
		next.step = now.step + 1;
		if(now.s && now.n != n){
			rest = n - now.n;
			if(rest >= now.s){
				next.s = 0;
				next.n = now.s + now.n;
			}
			else{
				next.s = now.s - rest;
				next.n = n;
			}
			next.m = now.m;
			if(!vis[next.n][next.m]){
				vis[next.n][next.m] = true;
				q.push(next);
			}
		}
		if(now.s && now.m != m){
			rest = m - now.m;
			if(rest >= now.s){
				next.s = 0;
				next.m = now.m + now.s;
			} 
			else{
				next.s = now.s - rest;
				next.m = m;
			}
			next.n = now.n;
			if(!vis[next.n][next.m]){
				vis[next.n][next.m] = true;
				q.push(next);
			}
		}
		if(now.n && now.s != s){
			rest = s - now.s;
			if(rest >= now.n){
				next.n = 0;
				next.s = now.s + now.n;
			}
			else{
				next.n = now.n - rest;
				next.s = s;
			}
			next.m = now.m;
			if(!vis[next.n][next.m]){
				vis[next.n][next.m] = true;
				q.push(next);
			}
		}
		if(now.n && now.m != m){
			rest = m - now.m;
			if(rest >= now.n){
				next.n = 0;
				next.m = now.m + now.n;
			}
			else{
				next.n = now.n - rest;
				next.m = m;
			}
			next.s = now.s;
			if(!vis[next.n][next.m]){
				vis[next.n][next.m] = true;
				q.push(next);
			}
		}
		if(now.m && now.s != s){
			rest = s - now.s;
			if(rest >= now.m){
				next.m = 0;
				next.s = now.s + now.m;
			}
			else{
				next.m = now.m - rest;
				next.s = s;
			}
			next.n = now.n;
			if(!vis[next.n][next.m]){
				vis[next.n][next.m] = true;
				q.push(next);
			}
		}
		if(now.m && now.n != n){
			rest = n - now.n;
			if(rest >= now.m){
				next.m = 0;
				next.n = now.n + now.m;
			}
			else{
				next.m = now.m - rest;
				next.n = n;
			}
			next.s = now.s;
			if(!vis[next.n][next.m]){
				vis[next.n][next.m] = true;
				q.push(next);
			}
		}
	}
	return -1;
}

int main()
{
	while(scanf("%d%d%d", &s, &n, &m) != EOF)
	{
		if(s == 0 && n == 0 && m == 0) break;
		if(s & 1){
			printf("NO\n");
			continue;
		}
		memset(vis, false, sizeof(vis));
		if(n < m) swap(n, m);
		int ans = bfs();
		if(ans == -1) printf("NO\n");
		else printf("%d\n", ans);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值