UVA - 725 Division (暴力枚举)

 Division 

Write a program that finds and displays all pairs of 5-digit numbers thatbetween them use the digits 0 through 9 once each, such that thefirst number divided by the second is equal to an integer N, where $2\le N \le 79$.That is,


abcde / fghij = N

where each letter represents a different digit. The first digit of one ofthe numerals is allowed to be zero.

Input 

Each line of the input file consists of a valid integer N. An input of zero is to terminatethe program.

Output 

Your program have to display ALL qualifying pairs of numerals, sorted byincreasing numerator (and, of course, denominator).

Your output should be in the following general form:


xxxxx / xxxxx = N

xxxxx / xxxxx = N

.

.


In case there are no pairs of numerals satisfying the condition, you mustwrite ``There are no solutions for N.". Separate the output for twodifferent values of N by a blank line.

Sample Input 

61
62
0

Sample Output 

There are no solutions for 61.

79546 / 01283 = 62
94736 / 01528 = 62


题目大意:

输入正整数n,按照从小到大的顺序输出所有形如abcde/fghij = n 的表达式,其中a~j恰好为数组0~9的一个排列(可以有前导0),2<= n <= 79

解析:

不需要枚举0~9所有的排列。只要枚举fghij就可以算出abcde,然后判断所有的数字都不相同即可。


#include <stdio.h>
#include <string.h>
bool judge(int ans1,int ans2) {
	char str[11];	
	bool vis[10];
	int num;
	memset(vis,false,sizeof(vis));
	sprintf(str,"%05d%05d",ans1,ans2);
	for(int i = 0; i < 10; i++) {
		num = str[i] - '0';
		if(vis[num]) {
			return false;
		}
		vis[num] = true;
	}
	return true;
}
int main() {
	int n;
	int ans1,ans2;
	int cas = 0;
	while(scanf("%d",&n) != EOF && n) {
		if(cas++) {
			printf("\n");
		}
		bool flag = false;
		for(int i = 1234; i <= 100000; i++) {
			if(i % n == 0) {
				ans2 = i / n;
				if( judge(i,ans2) ) {
					flag = true;
					printf("%05d / %05d = %d\n",i,ans2,n);	
				}
			}
		}
	
		if(!flag) {
			printf("There are no solutions for %d.\n",n);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值