UVA - 539 The Settlers of Catan (回溯水题)


  The Settlers of Catan 

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:


When the game ends, the player who built the longest road gains two extra victory points.


The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).


Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.


Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      \
o        o -- o        o -- o
               \      /
                o -- o

Input 

The input file will contain one or more test cases.

The first line of each test case contains two integers: the number of nodes n ( $2 \le n \le 25$) and the number of edges m ( $1 \le m \le 25$). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 for n and m.

Output 

For each test case, print the length of the longest road on a single line.

Sample Input 

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output 

2
12


题目大意:给你n个节点和,m条边,每条边长度为1,要求你求出最大路径长度。

解析:这是一道很基本的回溯题目,我敲出来一遍就过了,不懂的看下面代码。


#include <stdio.h>
#include <string.h>
const int N = 30;
const int INF = 0x3f3f3f;
int n,m;
int max;
int edge[N][N];
void dfs(int u,int sum) {
	for(int i = 0; i < n; i++) {
		if(edge[u][i]) {
			edge[u][i]--;
			edge[i][u]--;
			dfs(i,sum+1);
			edge[u][i]++;
			edge[i][u]++;
		}
	}
	if(sum > max) {
		max = sum;
	}
}
int main() {
	int u,v;
	while(scanf("%d%d",&n,&m) != EOF && (n || m)) {
		memset(edge,0,sizeof(edge));
		for(int i = 0; i < m; i++) {
			scanf("%d%d",&u,&v);
			edge[u][v]++;
			edge[v][u]++;
		}
		max = -INF;
		for(int i = 0; i < n; i++) {
			dfs(i,0);
		}
		printf("%d\n",max);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值