UVa 539 - The Settlers of Catan, 简单回溯

FILE539 - The Settlers of Catan3761
54.91%
1773
93.06%

题目链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=108&page=show_problem&problem=480


题目类型: 回溯法


原题:

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:


When the game ends, the player who built the longest road gains two extra victory points.


The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).


Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.


Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      \
o        o -- o        o -- o
               \      /
                o -- o

样例输入:

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0


样例输出:

2
12

题目大意:

输入一张无向图, 然后要求输出这张图最长的一条路径。 点可以重复走,但是边不能重复走。


思路与总结:

很简单的一道回溯递归题, 直接枚举所有点,然后从这个点开始递归搜索,记录路径数量,最后更新维护一个最大值。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define MAXN 30
using namespace std;
int n,m, G[MAXN][MAXN], vis[MAXN][MAXN], maxNum;


void dfs(int u, int num){
    for(int v=0; v<n; ++v){
        if(G[u][v] && !vis[u][v]){
            vis[u][v] = vis[v][u] = 1;
            dfs(v, num+1);
            vis[u][v] = vis[v][u] = 0;
        }
    }
    if(num > maxNum) maxNum = num;
}


int main(){
#ifdef LOCAL
    freopen("input.txt","r",stdin);
#endif
    int a,b;
    while(~scanf("%d %d", &n, &m)){
        if(!n && !m) break;
        memset(G, 0, sizeof(G));
        for(int i=0; i<m; ++i){
            scanf("%d %d", &a, &b);
            ++G[a][b];  ++G[b][a];
        }
        
        maxNum = -2147483645;
        for(int i=0; i<n; ++i){
            memset(vis, 0, sizeof(vis));
            dfs(i, 0);
        }
        printf("%d\n",maxNum);
    } 
    return 0;
}


——  生命的意义,在于赋予它意义。

 


          原创  http://blog.csdn.net/shuangde800  , By   D_Double  (转载请标明)





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值