pip安装包错误:Microsoft Visual C++ 14.0 is required问题解决方案

通过pycharm安装pyhanlp时,出现如下错误:

error: Microsoft Visual C++ 14.0 is required. 
Get it with “Microsoft Visual C++ Build Tools”: 
http://landinghub.visualstudio.com/visual-cpp-build-tools

方法1:

手动下载安装whl文件。(网上大部分推荐,但是没解决本人的问题)

下载链接:whl文件下载链接

网传找到需要下载的包,下载安装即可,但是这里并没有pyhanlp的相关包…另外,网传随便下载安装任一个都可以,本人尝试如下:

下载对应Python版本(cp36 对应 python3.6版本)、电脑win32或win64位的文件,在执行pip install ***,顺利的话可以解决问题。

方法2:

下载安装c++14.0。(完美解决问题)

由于报错是因为缺少Microsoft Visual C++ 14.0,所以最直接的做法就是下载安装VS。直接访问提示的链接(http://landinghub.visualstudio.com/visual-cpp-build-tools )时报错404 not found.....

网传该工具国内被墙了,无法直接下载,但是可以通过安装Visual C++解决。详情如下:

  • 选择“使用 C++ 的桌面开发”,选择默认的安装内容即可,网传也有要添加新的内容,链接如下,参考方案见:参考链接
  • 下载安装,速度比较慢,安装完成后页面如下:

  • 此时电脑中已经完成visual-cpp-build-tools 工具的安装,再次打开pycharm,执行pip install pyhanlp,即可完成安装:

总结:

  • Microsoft Visual C++ 14.0 is required 问题在pip安装包时偶尔发生,一般常见的包可以通过第一种方式解决,毕竟第二种方式要在电脑上安装部分的VS,下载速度较慢。
  • 对于下载的Microsoft Visual C++ 版本:

         Visual Studio 2013 ---> 12
         Visual Studio 2015 ---> 14
         Visual Studio 2017 ---> 15

         python3 是用 VC++ 14 编译的, python27 VC++ 9 编译的, 安装 python3 的包需要编译的也是要 VC++ 14 以上支持的.

         参考链接:参考链接

  • 使用Visual C++2015版本的同学,安装参考如下:

 

©️2020 CSDN 皮肤主题: 技术黑板 设计师:CSDN官方博客 返回首页