PAT 1082 Read Number in Chinese (25)

Given an integer with no more than 9 digits, you are supposed to read it in the traditional Chinese way. Output "Fu" first if it is negative. For example, -123456789 is read as "Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu". Note: zero ("ling") must be handled correctly according to the Chinese tradition. For example, 100800 is "yi Shi Wan ling ba Bai".

Input Specification:

Each input file contains one test case, which gives an integer with no more than 9 digits.

Output Specification:

For each test case, print in a line the Chinese way of reading the number. The characters are separated by a space and there must be no extra space at the end of the line.

Sample Input 1:

-123456789

Sample Output 1:

Fu yi Yi er Qian san Bai si Shi wu Wan liu Qian qi Bai ba Shi jiu

Sample Input 2:

100800

Sample Output 2:

yi Shi Wan ling ba Bai 

算法笔记里的代码,要好好理解消化一下。。

程序:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char num[10][5] = {"ling","yi","er","san","si","wu","liu","qi","ba","jiu"};
char wei[5][5] = {"Shi","Bai","Qian","Wan","Yi"};
int main()
{
  char str[15];
  scanf("%s",str);;
  int len = strlen(str);
  int left = 0,right = len - 1;
  if(str[0] == '-')
  {
    printf("Fu");
    left++;
  }
  while(left+4 <= right)
  {
    right -= 4;
  }
  while(left < len)
  {
    bool flag = false;
    bool isPrint = false;
    while(left <= right)
    {
      if(left > 0 && str[left] == '0')
      {
        flag = true;
      }
      else
      {
        if(flag == true)
        {
          printf(" ling");
          flag = false;
        }
        if(left > 0)
          printf(" ");
        printf("%s",num[str[left]-'0']);
        isPrint = true;
        if(left != right)
        {
          printf(" %s",wei[right-left-1]);
        }
      }
      left++;
    }
    if(isPrint == true && right != len - 1)
    {
      printf(" %s",wei[(len-1-right)/4+2]);
    }
    right += 4;
  }
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值