PAT 1110 Complete Binary Tree(25 分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:

YES 8

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:

NO 1

思路:把节点的左右节点保存下来,找到根节点,然后进行层次遍历,保存遍历结果。如果遍历结果中出现-1(空节点)后又出现非空节点,那么就不是完全二叉树。

 程序:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;
struct node
{
  int left = -1;
  int right = -1;
};
int main()
{
  int n;
  scanf("%d",&n);
  vector<struct node> v;
  int isChild[20] = {0};
  for(int i = 0; i < n; i++)
  {
    //getchar();
    char left[3],right[3];
    struct node temp;
    scanf("%s %s",left,right);
    if(left[0] != '-')
    {
      int tmp = static_cast<int>(left[0]-'0');
      if(left[1] != '\0')
        tmp = tmp * 10 + static_cast<int>(left[1]-'0');
      temp.left = tmp;
      isChild[temp.left] = 1;
    }
    if(right[0] != '-')
    {
      int tmp = static_cast<int>(right[0]-'0');
      if(right[1] != '\0')
        tmp = tmp * 10 + static_cast<int>(right[1]-'0');
      temp.right = tmp;
      isChild[temp.right] = 1;
    }
    v.push_back(temp);
  }
  int root = -1;
  for(int i = 0; i < n; i++)
  {
    if(isChild[i] == 0)
    {
      root = i;
      break;
    }
  }
  queue<int> q;
  vector<int> tree;
  q.push(root);
  //层次遍历,如果在最后一层前出现空节点就不是完全二叉树
  while(!q.empty())
  {
    int temp = q.front();
    tree.push_back(temp);//访问该节点
    if(temp != -1 && v[temp].left == -1)
      q.push(-1);
    else if(temp != -1 && v[temp].left != -1)
      q.push(v[temp].left);
    if(temp != -1 && v[temp].right == -1)
      q.push(-1);
    else if(temp != -1 && v[temp].right != -1)
      q.push(v[temp].right);
  //  printf("%d\n",q.front());
    q.pop();
  }
  bool flag = true;
  bool flg = true;
  int index = -1;
  for(int i = 0; i < tree.size(); i++)
  {
    if(tree[i] == -1)
    {
      flag = false;
      if(index == -1)
        index = i;
    }
    else if(tree[i] != -1 && !flag)
    {
      flg = false;
      break;
    }
  }
  if(flg)
    printf("YES %d\n",tree[index-1]);
  else
    printf("NO %d\n",root);
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值