天梯赛 L2-011 玩转二叉树 (25 分)

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

程序:

#include <cstdio>
#include <queue>
#include <vector>
#include <cstdlib>
using namespace std;
struct node
{
	int data;
	struct node *left,*right;
};
struct node* build(vector<int> pre,vector<int> in,int a,int b,int c,int d)
{
	if(a > b) return NULL;
	struct node* root = (struct node*)malloc(sizeof(struct node));
	root->data = pre[a];
	int pos = c;
	while(in[pos] != pre[a])
	{
		pos++;
	}
	root->left = build(pre,in,a+1,a+pos-c,c,pos-1);
	root->right = build(pre,in,a+pos-c+1,b,pos+1,d);
	return root;
}
void Reverse(struct node* &root)
{
	if(root)
	{
		Reverse(root->left);
		Reverse(root->right);
		struct node* temp = root->left;
		root->left = root->right;
		root->right = temp;
	}
}
void levelOrder(struct node* root)
{
	queue<struct node*> q;
	q.push(root);
	vector<int> v;
	while(!q.empty())
	{
		struct node* temp = q.front();
		v.push_back(temp->data);
		q.pop();
		if(temp->left)
			q.push(temp->left);
		if(temp->right)
			q.push(temp->right);
	}
	for(int i = 0; i < v.size(); i++)
	{
		if(i == 0)
			printf("%d",v[i]);
		else
			printf(" %d",v[i]);
	}
	printf("\n");
}
int main()
{
	int n;
	scanf("%d",&n);
	vector<int> pre(n),in(n);
	for(int i = 0; i < n; i++)
	{
		scanf("%d",&in[i]);
	}
	for(int i = 0; i < n; i++)
	{
		scanf("%d",&pre[i]);
	}
	struct node* root = build(pre,in,0,n-1,0,n-1);
	Reverse(root);
	levelOrder(root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值