uva-439 - HDOJ-1372-Knight Moves-翻译详解-BFS

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7012    Accepted Submission(s): 4238


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".
 

Sample Input
  
  
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 

Sample Output
  
  
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
 
本题讲的是国际象棋,和中国象棋差不多,而Knight 就相当于中国象棋中的马,马走日,只是说没有别腿,如题目所述,该棋盘共八行八列,用数字1-8表示行数,字母a-h表示列数;如输入第一组数据e2 e4,即表示从e 2 出发,到e 4 ;输出Knight 需要移动的次数,走法是日字形,每次可以走往八个方向,如下图:

。。



























看到这里,一切显而易见了,好水的BFS。。
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
char s1[3],s2[3];//A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
int visit[10][10];//编号为1——8的棋盘 
int stx,sty,endx,endy;
int f[8][2]={-2,1, -1,2, 1,2, 2,1, 2,-1, 1,-2, -1,-2, -2,-1};//Knight的八个移动方位
struct node
{
	int x,y,count;
};

void BFS(int x,int y)
{
	queue<node>q;
	node p,t;
	t.x=x;t.y=y;t.count=0;
	visit[t.x][t.y]=1;
	q.push(t);
	while(!q.empty())
	{
		t=q.front();
		q.pop();
		if(t.x==endx&&t.y==endy)
		{
			printf("To get from %s to %s takes %d knight moves.\n",s1,s2,t.count);
			return;
		} 
		for(int i=0;i<8;i++)
		{
			if((t.x+f[i][0]>0)&&(t.x+f[i][0]<9)&&(t.y+f[i][1]>0)&&(t.y+f[i][1]<9)&&!visit[t.x+f[i][0]][t.y+f[i][1]])
			{
				p.x=t.x+f[i][0];
				p.y=t.y+f[i][1];
				p.count=t.count+1;
				q.push(p);
			}
		}
	}
}
int main()
{
	while(~scanf("%s %s",s1,s2))
	{
		memset(visit,0,sizeof(visit));
		stx=s1[0]-'a'+1;
		sty=s1[1]-'0';
		endx=s2[0]-'a'+1;
		endy=s2[1]-'0';
		BFS(stx,sty);
	}
	return 0;
}
//*************************************版权所有,转载请注明出处,谢谢!****************************************//

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值