HDU 1026 Ignatius and the Princess I

Ignatius and the Princess I

                                                                      Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                                                   Total Submission(s): 14632    Accepted Submission(s): 4637
                                                                                                                                         Special Judge


Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 

Sample Input
  
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 

Sample Output
  
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
 

Author
Ignatius.L
 

题目链接 HDU 1026

题意:

求从一个网格的 (0, 0) 位置走到 (n - 1, m - 1) 位置的最小时间,其中 '.' 为路,'X' 是陷阱,不能走,'n' 为走此格子

需要耗费的时间。


分析:

广搜求最短路径,因为走每个格子花费的时间不同(有的需要 n 秒),因此用优先队列。

再用一个数组保存最优路径的当前位置是从他的哪个方向的位置走来的,最后递归打印最优路径即可。


代码:

#include <cstdio>
#include <cstring>
#include <cctype>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

struct pos
{
    int x, y, cnt;
    bool operator < (const pos& a) const    //时间小的优先
    {
        return cnt > a.cnt;
    }
} Now, Next;

const int dir[][2] = {0,1, 0,-1, 1,0, -1,0};
int R[105][105], vis[105][105];
char Map[105][105];
int n, m;

void print(int t, int x, int y)     //递归打印最优解路径
{
    if(x <= 0 && y <= 0) return;    //递归函数出口
    int tx = x - dir[R[x][y]][0];   //得到最优路径中上一个位置坐标
    int ty = y - dir[R[x][y]][1];

    if(isdigit(Map[x][y]))          //当前位置是数字
    {
        int k = Map[x][y] - '0';
        print(t - 1 - k, tx, ty);
        printf("%ds:(%d,%d)->(%d,%d)\n", t - k, tx, ty, x, y);
        for(int i = t - k + 1; i <= t; i++)
            printf("%ds:FIGHT AT (%d,%d)\n", i, x, y);
    }
    else
    {
        print(t - 1, tx, ty);
        printf("%ds:(%d,%d)->(%d,%d)\n", t, tx, ty, x, y);
    }
}

int bfs()
{
    priority_queue<pos> Q;
    Now.x = Now.y = Now.cnt = 0;
    Q.push(Now);                    //起点进队列
    vis[0][0] = 1;              //标记
    while(!Q.empty())
    {
        Now = Q.top();
        Q.pop();
        if(Now.x == n - 1 && Now.y == m - 1) return Now.cnt;    //到达目标位置
        for(int i = 0; i < 4; i++)
        {
            int tx = Now.x + dir[i][0];
            int ty = Now.y + dir[i][1];
            if(tx >= 0 && tx < n && ty >= 0 && ty < m && Map[tx][ty] != 'X' && !vis[tx][ty])
            {
                vis[tx][ty] = 1;        //标记已经访问
                R[tx][ty] = i;          //记录坐标(tx,ty)是由哪个方向走过来的,用于打印路径
                Next.x = tx;
                Next.y = ty;
                Next.cnt = Now.cnt + 1;
                if(isdigit(Map[tx][ty])) Next.cnt += Map[tx][ty] - '0';
                Q.push(Next);
            }
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d%d", &n, &m))
    {
        for(int i = 0; i < n; i++) scanf("%s", Map[i]);
        memset(vis, 0, sizeof(vis));
        int k = bfs();
        if(k == -1) printf("God please help our poor hero.\nFINISH\n");
        else
        {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n", k);
            print(k, n - 1, m - 1);
            printf("FINISH\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值