PTA甲级1077 Kuchiguse (20分)

首先,先贴柳神的博客

https://www.liuchuo.net/ 这是地址

想要刷好PTA,强烈推荐柳神的博客,和算法笔记

题目原题

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~  

Sample Output 1:

nyan~   

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T   

Sample Output 2:

nai

生词如下:

notorious 声名狼藉的

particles 粒子

stereotype 模式,模板

题目大意

就是给你若干个字符串,要你找出这些字符串的相同的尾缀

思路如下

① 把我们输入的字符串逆置先

② 在一个一个找他们相同的尾缀

代码如下

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int main(void) {
	string a[101];
	int N,i=0,min=257,flag=0;
	cin >> N;
	int N1 = N;
	cin.ignore();
	while (N--) {
		getline(cin, a[i]);
		if (min > a[i].length())
			min = a[i].length();
		reverse(a[i].begin(), a[i].end());
		i++;
	}

	i = 0;
	int ans = 0;
	for(; i < min; i++) {
		char b = a[0][i];
	
		for (int j = 1; j < N1; j++) {
			if (b != a[j][i]) {
				flag = 1;
				break;
			}
		}
		if (flag) {
			break;
		}
		else {
			ans++;
		}
	}

	if (ans==0)
		cout << "nai";
	else 
	for (int j = ans - 1; j >= 0; j--) {
		cout << a[0][j];
	}
	

	return 0;
}

下面请和我一起欣赏婼神的代码

#include <iostream>
#include <algorithm>
#include<cstring>
#include<string>

using namespace std;
int main() {
    int n;
    scanf("%d\n", &n);
    string ans;
    for (int i = 0; i < n; i++) {
        string s;
        getline(cin, s);
        int lens = s.length();
        reverse(s.begin(), s.end());
        if (i == 0) {
            ans = s;
            continue;
        }
        else {
            int lenans = ans.length();
            if (lens < lenans) swap(ans, s);    //
            int minlen = min(lens, lenans);
            for (int j = 0; j < minlen; j++) {
                if (ans[j] != s[j]) {
                    ans = ans.substr(0, j);
                    break;
                }
            }
        }
    }
    reverse(ans.begin(), ans.end());
    if (ans.length() == 0) ans = "nai";
    cout << ans;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值