首先,先贴柳神的博客
https://www.liuchuo.net/ 这是地址
想要刷好PTA,强烈推荐柳神的博客,和算法笔记
题目原文
According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6
生词如下:
consuming 消耗
repetition 重复
题目大意:
我的题目都没有看懂,我是看的算法笔记的题解
插入排序:就是一个一个的插入排序
归并排序:首先将原始序列看作N个只包含一个元素的有序子序列,然后每次迭代归并两个相邻的有序子序列,直到剩下最好一个有序的序列.
思路如下
① 写出插入的算法
② 写出归并的算法
代码如下:
#include<cstdio>
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int N = 111;
int origin[N], tempOri[N], changed[N]; //原始数组,原始数组备份,目标数组
int n; //元素个数
bool isSame(int A[], int B[]) { //判断数组A和数组B是否相同
for (int i = 0; i < n; i++) {
if (A[i] != B[i]) return false;
}
return true;
}
void showArray(int A[]) { //输出数组
for (int i = 0; i < n; i++) {
printf("%d", A[i]);
if (i < n - 1) printf(" ");
}
printf("\n");
}
bool insertSort() { //插入排序
bool flag = false; //记录是否存在数组中间步骤与changed数组相同
for (int i = 1; i < n; i++) { //进行n-1趟排序
if (i != 1 && isSame(tempOri, changed)) flag = true;
//中间步骤与目标相同,且不是初始序列
//以下为插入部分
int temp = tempOri[i], j = i;
while (j > 0 && tempOri[j - 1] > temp) {
tempOri[j] = tempOri[j - 1];
j--;
}
tempOri[j] = temp;
if (flag == true) return true; //如果flag为true,则说明以达到目标数组,返回true
}
return false; //无法达到目标数组,返回false
}
void mergeSort() { //归并排序
bool flag = false; //记录是否存在数组中间步骤与changed数组相同
for (int step = 2; step / 2 <= n; step *= 2) {
if (step != 2 && isSame(tempOri, changed)) {
flag = true; //中间步骤和目标步骤相同,且不是初始序列
}
for (int i = 0; i < n; i += step) sort(tempOri + i, tempOri + min(i + step, n));
if (flag == true) { //已达到目标数组,输出tempOri数组
showArray(tempOri);
return;
}
}
}
int main(void) {
scanf("%d", &n);
for (int i = 0; i < n; i++) {
scanf("%d", &origin[i]); //输入起始数组
tempOri[i] = origin[i]; //tempOri数组为备份,排序过程在tempOri上进行
}
for (int i = 0; i < n; i++) scanf("%d", &changed[i]); //目标数组
if (insertSort()) { //如果插入排序中找到目标数组
printf("Insertion Sort\n");
showArray(tempOri);
}
else { //到达此时一定是归并排序
printf("Merge Sort\n");
for (int i = 0; i < n; i++) {
tempOri[i] = origin[i]; //还原tempOri数组
}
mergeSort(); //归并排序
}
return 0;
}