原题链接:1089 Insert or Merge (25分)
关键词:插入排序、归并排序
According to Wikipedia:
Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.
Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.
Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in the first line either “Insertion Sort
” or “Merge Sort
” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6
题目大意: 给出你一组数和这组数经过某种排列的中间阶段,问你这是什么排序,并输出下一次排序。
分析:
- 原始序列和中间序列分别存为a[n]、b[n];
- 从b[n]中找到从左到右第一个不满足
b[i] <= b[i+1]
的数的下标,记为i; - 令j从i+1开始一直到n,如果均和原始序列一致,那就说明他是插入排序,下一次的结果就是sort(a, a+i+2)之后的a[n];
- 否则就是归并排序,直接对原来的序列进行模拟归并时候的归并过程,i从0到n/k,每次一段段得
sort(a + i * k, a + (i + 1) * k)
;最后别忘记还有最后剩余的不满足长度为k的部分的sort(a + n / k * k, a + n)
;这样是一次归并的过程。直到有一次发现a的顺序和b的顺序相同,则再归并一次,然后退出循环
代码:
// 7-2
#include <bits/stdc++.h>
using namespace std;
const int maxn = 110;
int n, a[maxn], b[maxn]; //a原始 b中间
vector<int> ans;
int main(){
scanf("%d", &n);
for(int i = 0; i < n; i ++ ) scanf("%d", &a[i]);
for(int i = 0; i < n; i ++ ) scanf("%d", &b[i]);
int i, j;
for(i = 0; i < n-1 && b[i] <= b[i+1]; i++); //i是满足从左到右递增的最后一个数的下标
for(j = i+1; a[j] == b[j] && j < n; j++);
//printf("%d %d\n", i, j);
if(j == n){
puts("Insertion Sort");
sort(a, a+i+2);
}
else{
puts("Merge Sort");
int k = 1; //步长
bool flag = true; //是否需要继续归并, flag=0也再归并一次再停止
while (flag) {
flag = 0;
for (i = 0; i < n; i++) {
if (a[i] != b[i])
flag = 1;
}
k = k * 2;
for (i = 0; i < n / k; i++)
sort(a + i * k, a + (i + 1) * k);
sort(a + n / k * k, a + n);
}
}
//输出
for(int i = 0; i < n; i ++ ){
if(i) printf(" ");
printf("%d", a[i]);
}
return 0;
}
也可以直接模拟两种排序的过程,判断中间序列与所给的中间序列是否相等:
代码来源:李小白~
#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
int n;
vector<int> a(100), b(100);
bool check(vector<int> temp){ //判断运行过程中是否和中间序列匹配
bool flag = true;
for(int i=0; i<n; i++){
if(temp[i] != b[i]){
flag = false;
break;
}
}
return flag;
}
void insertion(){ //插入排序
vector<int> temp = a;
bool flag = false;
for(int i=1; i<n; i++){
for(int j=0; j<i; j++){
if(temp[i] < temp[j]){
int t = temp[i];
temp.erase(temp.begin()+i);
temp.insert(temp.begin()+j, 1, t);
}
}
if(check(temp)){
flag = true;
continue;
}
if(flag){
printf("Insertion Sort\n");
for(int i=0; i<n; i++){
if(i)
printf(" ");
printf("%d", temp[i]);
}
break;
}
}
}
void merges(){ //归并排序
vector<int> temp = a;
bool flag = false;
int t = 1;
while(t <= n){
t *= 2;
for(int i=0; i<n; i+=t){
for(int j=i+1; j<i+t&&j<n; j++){
for(int k=i; k<j; k++){
if(temp[j] < temp[k]){
int c = temp[j];
temp.erase(temp.begin()+j);
temp.insert(temp.begin()+k, 1, c);
}
}
}
}
if(check(temp)){
flag = true;
continue;
}
if(flag){
printf("Merge Sort\n");
for(int i=0; i<n; i++){
if(i)
printf(" ");
printf("%d", temp[i]);
}
break;
}
}
}
int main(){
scanf("%d", &n);
for(int i=0; i<n; i++)
scanf("%d", &a[i]);
for(int i=0; i<n; i++)
scanf("%d", &b[i]);
insertion();
merges();
return 0;
}