PTA甲级 1040 Longest Symmetric String (25分)

强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解
算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given Is PAT&TAP symmetric?, the longest symmetric sub-string is s PAT&TAP s, hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

生词如下:

symmetric 对称的

sub-string 子串

题目大意:

给你字符串,要你找出最长的对称子串

我的土鳖代码:

#include<iostream>
#include<string>
using namespace std;
int main(void) {
	string a;
	getline(cin, a);
	int len = a.length();
	int begin = 0, end = 0;
	int result = 1;
	for (int i = 0; i < len; ++i) {
		begin = i - 1; end = i + 1;
		while (begin >= 0 && end <len) {
			if (a[begin] == a[end]) {
				if (end - begin + 1 > result) result = end - begin + 1;
				--begin;
				++end;
			}
			else break;
		}

		begin = i; end = i + 1;
		while(begin >= 0 && end < len) {
			if (a[begin] == a[end]) {
				if (end - begin + 1 > result) result = end - begin + 1;
				--begin;
				++end;
			}
			else break;
		}
	}
	cout << result;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值