LeedCode-733. Flood Fill

强烈推荐,刷PTA的朋友都认识一下柳神–PTA解法大佬

不刷也可以认识一下

本文由参考于柳神博客写成

柳神的CSDN博客,这个可以搜索文章

柳神的个人博客,这个没有广告,但是不能搜索

还有就是非常非常有用的 算法笔记 全名是

算法笔记  上级训练实战指南		//这本都是PTA的题解算法笔记

PS 今天也要加油鸭

在这里插入图片描述

题目原文

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1,Q2,⋯,Q**N), where Q**i is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

8q.jpg9q.jpg
Figure 1Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format “N Q1 Q2 … Q**N”, where 4≤N≤1000 and it is guaranteed that 1≤Q**iN for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4结尾无空行

Sample Output:

YES
NO
NO
YES结尾无空行

生词如下:

queen 女王

Puzzle 困惑

threaten each other

threaten 威胁

diagonal 对角线

column 列

row 行

题目大意:

简单来说,就是让你判断一下是不是Not Queens

然后还有一点要注意的是,

那个列是从右到左的

然后就是让你判断会不会打起来

棋子是不是同一行,同一列,是不是同一个对角线

代码如下:

#include<iostream>
#include<vector>
#include<set>
using namespace std;
int main(void) {
	int K=0,t=0,N=0;
	scanf("%d", &K);
	set<int> Test_Dig;
	set<int> Test_row;
	for (int j = 0; j < K; ++j) {
		scanf("%d", &N);
		for (int i = 0; i < N; ++i) {
			scanf("%d", &t);
			Test_row.insert(t);
			Test_Dig.insert(i - t);
		}
		if (Test_Dig.size() != N || Test_row.size() != N)	printf("NO");
		else printf("YES");
		if (j != K - 1)	printf("\n");
		Test_row.clear();
		Test_Dig.clear();
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值