POJ 2051 Argus(按周期输出)



Argus
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9674 Accepted: 4509

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 

For the Argus, we use the following instruction to register a query: 
Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005

Source



题目大意:

   这一题输入数据每一行给你一个编号,再给你它每一次出现的间隔时间,最后以“#”结束,在末尾还有一个k,然后让你根据他们出现的时间从早到晚把前k个编号打印出来,若在同一时间有多个编号,那么先输出小的编号。


解题思路:

优先队列。


代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<queue>

using namespace std;
struct node{
	int Q_num;
	int Period;
	int nextTime;
	node(int Q_num0=0,int Period0=0,int nextTime0=0){
		Q_num=Q_num0,Period=Period0,nextTime=nextTime0;
	}
	friend bool operator < (node a,node b){
        if(a.nextTime!=b.nextTime) return a.nextTime > b.nextTime;
		return a.Q_num > b.Q_num;
	}

}Register;

priority_queue <node> pq;

int main(){
	string str;
	int Q_num;
	int Period;
	int t;
	while(cin>>str&&str!="#"){
		cin>>Q_num>>Period;
		Register.Q_num=Q_num;
		Register.Period=Period;
		Register.nextTime=Period;
		pq.push(Register);
	}
    cin>>t;
	//while(!pq.empty()) {cout<<pq.top().Q_num<<endl;pq.pop();}
	while(t--){
		Register=pq.top();
		cout<<Register.Q_num<<endl;
		Register.nextTime+=Register.Period;
		pq.pop();
		pq.push(Register);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值