POJ 3678 Katu Puzzle (2-SAT)

任重而道远

题目大意:

  有一个大小为N的集合={x1,x2..xn},xi=0或1,现在给出它们之间的一些逻辑运算的结果(比如x1 and x2=1),逻辑运算有AND OR XOR三种,问是否存在一种满足所有条件的取值方案。

Description

Katu Puzzle is presented as a directed graph G(VE) with each edge e(a, b) labeled by a boolean operator op (one of AND, OR, XOR) and an integer c (0 ≤ c ≤ 1). One Katu is solvable if one can find each vertex Vi a value Xi (0 ≤ X≤ 1) such that for each edge e(a, b) labeled by op and c, the following formula holds:

 Xa op Xb = c

The calculating rules are:

AND01
000
101
OR01
001
111
XOR01
001
110

Given a Katu Puzzle, your task is to determine whether it is solvable.

Input

The first line contains two integers N (1 ≤ N ≤ 1000) and M,(0 ≤ M ≤ 1,000,000) indicating the number of vertices and edges.
The following M lines contain three integers (0 ≤ a < N), b(0 ≤ b < N), c and an operator op each, describing the edges.

Output

Output a line containing "YES" or "NO".

Sample Input

4 4
0 1 1 AND
1 2 1 OR
3 2 0 AND
3 0 0 XOR

Sample Output

YES

Hint

X 0 = 1,  X 1 = 1,  X 2 = 0,  X 3 = 1.


AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <iostream>
#include <cstdlib>

using namespace std;

const int maxn = 2010;
const int maxm = maxn * maxn;

struct edge
{
	int v,next;
}e[maxm];
int h[maxn],num;
int n,m,nn;
int indexx,dfn[maxn],low[maxn],place[maxn];
int stack[maxn],top,cnt;
bool vis[maxn];

void build(int u,int v)
{
	num++;
	e[num].v = v;
	e[num].next = h[u];
	h[u] = num;
}

void tarjan(int u)
{
	int v;
	dfn[u] = low[u] = ++indexx;
	stack[++top] = u;
	vis[u] = true;
	for(int i = h[u]; i; i = e[i].next)
	{
		v = e[i].v;
		if(!dfn[v])
		{
			tarjan(v);
			if(low[v] < low[u])
				low[u] = low[v];
		}
		else if(vis[v] && dfn[v] < low[u])
			low[u] = dfn[v];
	}
	if(dfn[u] == low[u])
	{
		cnt++;
		while(1)
		{
			int x = stack[top--];
			vis[x] = false;
			place[x] = cnt;
			if(x == u)
				break;
		}
	}
}

void build_edge(int x,int y,int z,char *s)
{
	if(!strcmp(s,"AND"))
	{
		if(z == 1)
		{
			build(x+n,x);
			build(y+n,y);
			build(x,y);
			build(y,x);
		}
		else
		{
			build(x,y+n);
			build(y,x+n);
		}
	}
	if(!strcmp(s,"OR"))
	{
		if(z == 0)
		{
			build(x,x+n);
			build(y,y+n);
			build(x+n,y+n);
			build(y+n,x+n);
		}
		else
		{
			build(y+n,x);
			build(x+n,y);
		}
	}
	if(!strcmp(s,"XOR"))
	{
		if(z == 0)
		{
			build(x,y);
			build(y,x);
			build(x+n,y+n);
			build(y+n,x+n);
		}
		else
		{
			build(x,y+n);
			build(y+n,x);
			build(x+n,y);
			build(y,x+n);
		}
	}
}

int main()
{
	cin >> n >> m;
	nn = 2 * n;
	int x,y,z;
	char s[8];
	for(int i = 1; i <= m; i++)
	{
		scanf("%d%d%d%s",&x,&y,&z,s);
		x++, y++;
		build_edge(x,y,z,s);
	}
	for(int i = 1; i <= nn; i++)
		if(!dfn[i])
			tarjan(i);
	bool ans = true;
	for(int i = 1; i <= n; i++)
		if(place[i] == place[i+n])
		{
			ans = false;
			break;
		}
	if(ans)
		printf("YES\n");
	else
		printf("NO\n");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值