NYOJ:546 Divideing Jewels

Divideing Jewels

时间限制: 1000  ms  |  内存限制: 65535  KB
难度: 4
描述

Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

输入
Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000.  
The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line.  
输出
For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".  
Output a blank line after each test case.  
样例输入
1 0 1 2 0 0 0 0 2 0              价值为i+1的物品有a[i]个。
1 0 0 0 1 1 0 0 0 0
0 0 0 0 0 0 0 0 0 0
样例输出
#1:Can't be divided.

#2:Can be divided.

#include <iostream>
#include <cstdio>
#include <string.h>
#define maxx(a,b) a>b?a:b
using namespace std;
int b[120008],f[120008],t=1;
int main()
{
    int a[15];
    while(1)
    {
        int i,j,sum,k,w;
        f[0]=0;
        memset(f+1,0xc0,sizeof(int)*120007);          //除第一个其他赋值为“负无穷”
        memset(b,0,sizeof(b));                                    //将数组清零
        sum=0;                            
        for(i=0;i<10;i++)
        {
                scanf("%d",&a[i]);          //输入价值为i+1的弹珠的数量
                sum+=a[i]*(i+1);            //边输入边计算sum,
        }
        if(sum == 0)                         //sum == 0代表所有的弹珠数量都为0,结束循环
            break;
        if(sum%2)                           //如果总价值是奇数一定不能平分,直接输出结果
            {printf("#%d:Can't be divided.\n\n",t++);continue;}
        else
        {
            for(i=1,k=0;i<11;i++)
            {
                for(j=i,w=a[i-1]*i;j<w;j*=2)         //将多重背包转化成01背包,j为价值,w为总价值,
                {                                                  //进行一种二进制转换防止超时
                    b[k++]=j;                                //价值存在b[k]数组中;
                    w-=j;                                         //剩余价值
                }
                b[k++]=w;
            }
            sum/=2;//取总价值一半
            for(i=0;i<k+1;i++)//01背包状态转移方程
                for(j=sum;j>=b[i];j--)
                    f[j]=maxx(f[j],f[j-b[i]]+b[i]);
            if(f[sum]<0)                                    //如果能恰好平分则装满的背包一定是正数
                printf("#%d:Can't be divided.\n\n",t++);
            else
                printf("#%d:Can be divided.\n\n",t++);
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值