HDU 2955-Robberies(01背包+概率)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28110    Accepted Submission(s): 10323


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
 
 
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
 
 
2 4 6
 

Source
题目大意:一个人去抢劫银行,有n个银行给他抢,抢第i个银行的利润为Mi被抓的概率为Pi,让你求在被抓的概率不超过限定概率的情况下,能抢到的钱最多是多少?


解题思路:这里牵扯到了概率问题,不知到大家还记得高中的知识吗?题目要求,不要被抓到,所以我们在抢每个银行的时候都不能被抓,所以 不被抓的概率为所抢银行不被抓的概率的乘积为 p =(1-p1)*(1-p2)....,最后输出满足1-p<=maxp的最大利润就可以了。我们dp[j] = max(dp[j],  dp[j-M[i]]]*(1-Pi))表示抢了j块钱不被抓的最大概率,最后我们贪心一下即可。

AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<set>
#include<queue>
#define N 110

using namespace std;

int T, n, m[N], maxm;
double p[N], dp[N*100], maxp;

int main()
{
    scanf("%d", &T);
    while(T --) {
        memset(dp, 0, sizeof(dp));
        scanf("%lf%d", &maxp, &n);
        maxm = 0;
        dp[0] = 1;
        for(int i = 0; i < n; i ++) {
            scanf("%d%lf", &m[i], &p[i]);
            maxm += m[i];
        }
        for(int i = 0; i < n; i ++) {
            for(int j = maxm; j >= m[i]; j --) {
                dp[j] = max(dp[j], dp[j-m[i]]*(1-p[i]));
            }
        }
        for(int i = maxm; i >= 0; i --) { //贪心输出最大
            if(dp[i] >= 1-maxp) {
                printf("%d\n", i); break;
            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值