POJ 3281 Dining (最大流)

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17065 Accepted: 7562

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 

The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.


题意:有N头牛、F种食物和D种饮料,每头牛有自己喜欢的食物喝饮料,每种食物或饮料只能供一头牛享用,每头牛都想分配到自己喜欢的一种食物和一种饮料,问最多能满足几头牛的要求。


思路:不难想到应用图论的只是来解决。因为食物和饮料与牛都有关系,所以将牛放在中间,将它和喜欢的食物之间连一条容量为1的边,将它和喜欢的饮料之间连一条容量为1的边。因为每头牛只能吃一份,所以将牛拆点,中间连一条容量1的边。最后求最大流即可。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
#include<algorithm>
#include<string>
#include<queue>
#include<map>
using namespace std;
const int maxn = 500 + 10;
const int INF = 0x3f3f3f3f;
struct Edge {
  int from, to, cap, flow;
  Edge(int u, int v, int c, int f):from(u),to(v),cap(c),flow(f) {}
};
struct Node {
  int u, v;
  int cap, st, ed;
}node[maxn];

struct Dinic {
   int n, m, s, t;
   vector<Edge> edges;
   vector<int> G[maxn];
   bool vis[maxn];
   int d[maxn], cur[maxn];

   void init(int n) {
     for(int i = 0; i <= n; i++) G[i].clear();
     edges.clear();
   }

   void AddEdge(int from, int to, int cap) {
     edges.push_back(Edge(from, to, cap, 0));
     edges.push_back(Edge(to, from, 0, 0));
     m = edges.size();
     G[from].push_back(m-2);
     G[to].push_back(m-1);
   }

   bool BFS() {
     memset(vis, 0, sizeof vis);
     queue<int> Q;
     Q.push(s);
     d[s] = 0;
     vis[s] = 1;
     while(!Q.empty()) {
        int x = Q.front(); Q.pop();
        for(int i = 0; i < G[x].size(); i++) {
           Edge& e = edges[G[x][i]];
           if(!vis[e.to] && e.cap > e.flow) {
              vis[e.to] = 1;
              d[e.to] = d[x] + 1;
              Q.push(e.to);
           }
        }
     }
     return vis[t];
   }

   int DFS(int x, int a) {
      if(x == t || a == 0) return a;
      int flow = 0, f;
      for(int& i = cur[x]; i < G[x].size(); i++) {
         Edge& e = edges[G[x][i]];
         if(d[x] + 1 == d[e.to] && (f = DFS(e.to, min(e.to, min(a, e.cap-e.flow)))) > 0) {
            e.flow += f;
            edges[G[x][i]^1].flow -= f;
            flow += f;
            a -= f;
            if(a == 0) break;
         }
      }
      return flow;
   }

   int Maxflow(int s, int t) {
     this->s = s; this->t = t;
     int flow = 0;
     while(BFS()) {
        memset(cur, 0, sizeof cur);
        flow += DFS(s, INF);
     }
     return flow;
   }
}dinic;

int main() {
  int N, F, D;
  scanf("%d%d%d", &N, &F, &D);
  for(int i = 1; i <= N; i++) {
    dinic.AddEdge(2*i-1, 2*i, 1); //拆点
    int f, d, x;
    scanf("%d%d", &f, &d);
    for(int j = 1; j <= f; j++) {
      scanf("%d", &x);
      dinic.AddEdge(2*N+x, 2*i-1, 1); //牛与食物
    }
    for(int j = 1; j <= d; j++) {
      scanf("%d", &x);
      dinic.AddEdge(2*i, 2*N+F+x, 1); //牛与饮料
    }
  }
  for(int i = 1; i <= F; i++)
    dinic.AddEdge(0, 2*N+i, 1);
  for(int i = 1; i <= D; i++)
    dinic.AddEdge(2*N+F+i, 2*N+F+D+1, 1);
  printf("%d\n", dinic.Maxflow(0, 2*N+F+D+1));
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值