HDU 5441 Travel (离线处理+并查集)

Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2914    Accepted Submission(s): 998


Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are n cities and m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is x minutes, how many pairs of city (a,b) are there that Jack can travel from city a to b without going berserk?
 

Input
The first line contains one integer T,T5 , which represents the number of test case.

For each test case, the first line consists of three integers n,m and q where n20000,m100000,q5000 . The Undirected Kingdom has n cities and m bidirectional roads, and there are q queries.

Each of the following m lines consists of three integers a,b and d where a,b{1,...,n} and d100000 . It takes Jack d minutes to travel from city a to city b and vice versa.

Then q lines follow. Each of them is a query consisting of an integer x where x is the time limit before Jack goes berserk.

 

Output
You should print q lines for each test case. Each of them contains one integer as the number of pair of cities (a,b) which Jack may travel from a to b within the time limit x .

Note that (a,b) and (b,a) are counted as different pairs and a and b must be different cities.
 

Sample Input
  
  
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

Sample Output
  
  
2 6 12
 题意:给你一个n个点m条边的无向图,问有多少个点对(a,b)满足从点a到点b的路长不超过d(不超过的意思是每一条路都不超过,但是总的路长可能超过)
思路:将要查询的值排序保存起来,然后按顺序查找,利用并查集,若某条边的两个点祖先不同,则增加的点对数就是两个点集合数目的乘积的两倍。
#include<cstdio>
#include<cstring>
#include<vector>
#include<iostream>
#include<algorithm>
#include<queue>
#include<set>
#include<map>
using namespace std;
typedef long long ll;
typedef pair<int, int> P;
const int maxn = 1e5 + 10;
int pre[maxn], num[maxn];
ll ans[maxn];

struct Edge
{
    int from, to, value, color;
    Edge(int from = 0, int to = 0, int value = 0) : from(from), to(to), value(value){ color = 0; }
    void read()
    {
        scanf("%d%d%d",&from,&to,&value);
    }
    bool operator < (const Edge& b) const
    {
        return value < b.value;
    }
}edge[maxn];

struct Out
{
    int x, id;
    bool operator < (const Out& b) const
    {
        return x < b.x;
    }
}out[maxn];

int find(int x)
{
    return pre[x] == x ? x : pre[x] = find(pre[x]);
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--) {
        int n, m, q;
        scanf("%d%d%d",&n,&m,&q);
        for (int i = 0; i < m; i++) edge[i].read();
        for (int i = 0; i < q; i++) {
            scanf("%d",&out[i].x);
            out[i].id = i;
        }
        sort(edge, edge + m);
        sort(out, out + q);
        for (int i = 1; i <= n; i++) pre[i] = i, num[i] = 1;
        int j = 0;
        ll cnt = 0;
        for (int i = 0; i < q; i++) {
            while (j < m && edge[j].value <= out[i].x) {
                int x = edge[j].from;
                int y = edge[j].to;
                int fx = find(x), fy = find(y);
                if (fx != fy) {
                    cnt += (ll)num[fx] * num[fy] * 2;
                    pre[fy] = fx;
                    num[fx] += num[fy];
                }

                j++;
            }
            ans[out[i].id] = cnt;
        }
        for (int i = 0; i < q; i++)
            printf("%d\n",ans[i]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值