POJ Buy Tickets【线段树】

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 21250 Accepted: 10406
Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output

77 33 69 51
31492 20523 3890 19243
Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

Source

POJ Monthly–2006.05.28, Zhu, Zeyuan

题意,有n个人分别有自己想要的位置和pos和自己的代号(价值)val。从第一个人开始抢位置,输出最后位置上的代号情况。

从后面来看,最后一个人肯定能抢到自己的位置。依次往前,每一个人的位置取决于他之后是否有人抢占了他自己或前面的位置,以此类推。
由此, 可用线段树来储存之前有多少人,在其之前。

#include<iostream>
#include<cstdio>
using namespace std;
//永远不要小瞧人生
const int N = 200005;
struct node
{
    int l, r, w;
}tree[3*N];
int n, id, pos[N], val[N], ans[N];
void build(int k, int left, int right)//构建线段树
{
    tree[k].l = left;
    tree[k].r = right;
    tree[k].w = right - left + 1;//记录区间空位
    int mid = (left + right >> 1);
    if (left < right)
    {
        build(k << 1, left, mid);//2*k
        build(k << 1 | 1, mid + 1, right);//2*k+1
    }
}
void updata(int k, int pos)//元素插入
{
    tree[k].w--;
    if (tree[k].l == tree[k].r)
    {
        id = tree[k].l;
        return;
    }
    if (tree[k << 1].w >= pos) updata(k << 1, pos);
    else
    {
        pos -= tree[k << 1].w;
        updata(k << 1 | 1, pos);
    }
}
int main()
{
    while (scanf("%d", &n) == 1)
    {
        build(1, 1, n);
        for (int i = 1; i <= n; i++)
        {
            scanf("%d%d", &pos[i], &val[i]);
        }
        for (int i = n; i >= 1; i--)//倒序确定
        {
            updata(1, pos[i] + 1);
            ans[id] = val[i];
        }
        for (int i = 1; i <= n; i++)
        {
            printf("%d ", ans[i]);
        }
        putchar('\n');
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值