POJ 2299 Ultra-QuickSort【线段树】

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 64050 Accepted: 23920
Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input

5
9
1
0
5
4
3
1
2
3
0
Sample Output

6
0
Source

Waterloo local 2005.02.05

从今天起,打死不用小写的l,简直有毒= =。

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 5e5 + 5;
#define LL long long int
#define lson k<<1,   l,   mid
#define rson (k<<1)|1, mid + 1, r
int n, a[maxn], t[maxn];
LL ans;
int Tree[maxn << 2], index[maxn], num[maxn];
//int n;
bool cmp(const int i, const int j)
{
    return num[i] < num[j];
}
void Edit(int k,int l,int r,int num,int value)
{
    Tree[k] += value;
    if (r == l)
        return ;
    int mid = (l + r) >> 1;
    if (num <= mid)
        Edit(lson, num, value);
    else
        Edit(rson, num, value);
}
int Search(int k, int l, int r, int L, int R)
{
    if (L <= l && r <= R)
        return Tree[k];
    int mid = (l + r) >> 1;
    int ans = 0;
    if (L <= mid)
        ans += Search(lson, L, R);
    if (R > mid)
        ans += Search(rson, L, R);
    return ans;
}
int main()
{
    while (cin >> n&&n)
    {
        memset(Tree, 0, sizeof(Tree));
        memset(num, 0, sizeof(num));
        memset(index, 0, sizeof(num));
        for (int i = 1; i <= n; i++)
        {
            cin >> num[i];
            Edit(1, 1, n, i, 1);
            index[i] = i;
        }
        sort(index + 1, index + 1 + n, cmp);
        LL ans = 0;
        for (int i = 1; i <= n; i++)
        {
            ans += (Search(1, 1, n, 1, index[i]) - 1);
            Edit(1, 1, n, index[i], -1);
        }
        cout << ans << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值