AtCoder Beginner Contest 069 D - Grid Coloring

D - Grid Coloring


Time limit : 2sec / Memory limit : 256MB

Score : 400 points

Problem Statement

We have a grid with H rows and W columns of squares. Snuke is painting these squares in colors 12N. Here, the following conditions should be satisfied:

  • For each i (1iN), there are exactly ai squares painted in Color i. Here, a1+a2++aN=HW.
  • For each i (1iN), the squares painted in Color i are 4-connected. That is, every square painted in Color i can be reached from every square painted in Color i by repeatedly traveling to a horizontally or vertically adjacent square painted in Color i.

Find a way to paint the squares so that the conditions are satisfied. It can be shown that a solution always exists.

Constraints

  • 1H,W100
  • 1NHW
  • ai1
  • a1+a2++aN=HW

Input

Input is given from Standard Input in the following format:

H W
N
a1 a2  aN

Output

Print one way to paint the squares that satisfies the conditions. Output in the following format:

c11  c1W
:
cH1  cHW

Here, cij is the color of the square at the i-th row from the top and j-th column from the left.


Sample Input 1

Copy
2 2
3
2 1 1

Sample Output 1

Copy
1 1
2 3

Below is an example of an invalid solution:

1 2
3 1

This is because the squares painted in Color 1 are not 4-connected.


Sample Input 2

Copy
3 5
5
1 2 3 4 5

Sample Output 2

Copy
1 4 4 4 3
2 5 4 5 3
2 5 5 5 3

Sample Input 3

Copy
1 1
1
1

Sample Output 3

Copy
1

       这次明明是一次很简单的四连块填进格子的问题。。然后因为一开始的理解错误到最后都没有写出来,心疼自己,所以早上就来补题了。思路上没有什么难度,主要就是要实现一个‘ S ’形的方式进行储存。

#include <cstdio>
#include <iostream>
using namespace std;
int pd[110][110];
int main(){
	int h,w,n,x=0;
	cin>>h>>w>>n;
	int a[n];
	for(int i=0;i<n;i++){
		cin>>a[i];
		for(int j=0;j<a[i];j++){
			if((x/w)%2==0) pd[x/w][x%w]=i+1;
			else pd[x/w][w-(x%w)-1]=i+1;
			x++;
		}
	}
	for(int i=0;i<h;i++){
		for(int j=0;j<w;j++){
			if(j==w-1) printf("%d\n",pd[i][j]);
			else printf("%d ",pd[i][j]);
		}
	}
	return 0;
}


虽然这次还是没有做出来,可是为了最后一题做Beginner好蠢,下次决定要开始做下个级别的了。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值