apt-get install 遇到依赖问题

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/JNingWei/article/details/73436979

方法一 :

askubuntu.com/questions/140246/how-do-i-resolve-unmet-dependencies-after-adding-a-ppa

需要用到的部分是用了里面排名最高的回答的

Solutions:

Disable/Remove/Purge PPAs:

里的解决步骤

ps: 这是目前唯一一个试成了的方法

我个人实际操作时仅在

sudo apt-get autoremove –purge package-name

一句根据具体情况做了改动
另外

Additional Sources:

里的 Y-PAA-Manager 没装上,后来看来可不装

方法二:

更换源,随后更新:

sudo apt-get update

删除 /var/lib/apt/lists 下的所有文件

如果还是解决不了问题,另寻办法



展开阅读全文

没有更多推荐了,返回首页