YTU.3155: 贪心之Packets

3155: 贪心之Packets

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 8   Solved: 7
[ Submit][ Status][ Web Board]

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

AC代码:

#include <stdio.h>
int main()
{
    int N, a, b, c, d, e, f, y, x;
    int u[4]= {0, 5, 3, 1};
    while(1)
    {
        scanf("%d%d%d%d%d%d", &a, &b, &c, &d, &e, &f);
        if (a == 0 && b == 0 && c == 0 && d == 0 && e == 0 && f == 0) 
            break;
        N = f + e + d + (c + 3) / 4;
        y = 5 * d + u[c % 4];
        if(b > y) N += (b - y + 8 ) / 9;
        x = 36 * N - 36 * f - 25 * e - 16 * d - 9 * c - 4 * b;
        if(a > x) N += ( a - x + 35 ) / 36;
        printf("%d\n", N);
    }
    return 0;
}
题目详解:
http://blog.csdn.net/dongfengkuayue/article/details/6461374

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎曼猜想·

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值