1038 Recover the Smallest Number (30分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤10
​4
​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287

据说也是个贪心算法,但我还是不太看得出。这道题的重点要两个,一个是把放在前面比较小的数放在前面,一个是不输出前导0。
把放在前面比较小的数放在前面,用sort就可以解决,一开始我是判断第一个数字啥啥啥的,反正就是不对。后面参考了别人的,发现只要return s1 + s2 < s2 + s1就可以了,这个意思就是s1放在前面比s2放在前面要小。
不输出前导0可以用熟悉的erase()函数,while循环,如果当前长度不为0,且第一位为0就s.erase(s.begin())。erase()的参数是迭代器。这样一轮循环后,前导0就没了。如果s的长度为0,证明要输出0(防止s没东西),最后输出s

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
bool cmp(string s1, string s2){
    return s1 + s2 < s2 + s1;
}

int main(){
    int n;
    cin>>n;
    vector<string> v(n+1);
    for(int i = 0; i < n; i++){
        cin>>v[i];
    }
    string s;
    sort(v.begin(),v.begin()+n,cmp);
    for(int i = 0; i < n; i++){
        s += v[i];
    }
    while(s.length() != 0 && s[0] == '0'){
        s.erase(s.begin());
    }
    if(s.length() == 0) cout<<"0";
    cout<<s;
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值