PAT-A1038 Recover the Smallest Number 题目内容及题解

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​^4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

题目大意

题目给出一组数据片段,求其可以组成的最小的数字并输出。

解题思路

  1. 读入所有数据片段,并排序,排序依据为使a+b<b-a(贪心法);
  2. 将排好序的数据片段连接起来,并去除首位0,直到其首位非零或为空;
  3. 如结果非空输出结果,否则输出“0”(边界条件)。
  4. 返回零值。

代码

#include<iostream>
#include<algorithm>
#include<string>
#define maxn 10010
using namespace std;
bool cmp(string a,string b){
    return a+b<b+a;
}

int main(){
    int i,N;
    string a[maxn],sum;
    cin>>N;
    sum.clear();
    for(i=0;i<N;i++){
        cin>>a[i];
    }
    sort(a,a+N,cmp);
    for(i=0;i<N;i++){
        sum+=a[i];
    }
    while(sum.size()!=0&&sum[0]=='0'){
        sum.erase(sum.begin());
    }
    if(sum.size()==0){
        cout<<"0"<<endl;
    }else{
        cout<<sum<<endl;
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值