1140 Look-and-say Sequence (20分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:
Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:
Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
Sample Output:
1123123111

一开始就是死活看不懂题目,但是做过坏键盘那道题之后和这个有异曲同工之妙

#include<iostream>
#include<cstring>
using namespace std;
int main(){
    string d;
    int n;
    cin>>d>>n;
    if(n == 1){
        cout<<d;
        return 0;
    }
    for(int i = 0; i < n-1; i++){
        string sequence = "";
        for(int j = 0; j < d.length();){
            char c = d[j];
            int start = j;
            while(j < d.length() && d[j]==c) j++;//此时找到的j是第一位和c不同的下标
            sequence += c;
            sequence += (j-start+'0');
        }
        d = sequence;
    }
    cout<<d;
    return 0;
}

再做一遍还是不行,如果n等于1直接输出最后结果。计算相同字符个数的时候要注意j<s.length(),不能越界了,不然会报错

#include<iostream>
using namespace std;
int main(){
    string s;
    int n;
    cin>>s>>n;
    if(n==1){
        cout<<s;
        return 0;
    }
    for(int i = 1; i < n; i++){
        string str = "";
        for(int j = 0; j < s.length();){
            char c = s[j];
            int start = j;
            while(s[j] == c && j < s.length()) j++;
            str += c+to_string(j-start);
        }
        s = str;
    }
    cout<<s;
    return 0;
}

三刷:自己做的
自己建模,记录当前位是啥,还有当前位的序号,往后找,直到找到第一个不为当前位的,用j-记录下的序号,就是有几个相同的数,在temp后面加上当前位和字符串形式的个数即可。循环n-1次

//循环n次,每次从前往后遍历,如果相等就一直++,然后在本轮字符串的结尾处加上字符串形式的j-i
//直到找到第一个不等的,然后个数就是,如果不等就break
#include<iostream>
using namespace std;
int main(){
    string s;
    int n;
    cin>>s>>n;
    for(int i = 1; i < n; i++){
        string temp="";
        for(int j = 0; j < s.length();){
            int start = j;
            char c = s[j];
            while(s[start] == s[j]) j++; 
            temp += c + to_string(j-start);
        }
        s = temp;
    }
    cout<<s;
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值