1155 Heap Paths (30分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:
8
98 72 86 60 65 12 23 50
Sample Output 1:
98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
Sample Input 2:
8
8 38 25 58 52 82 70 60
Sample Output 2:
8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56
Sample Output 3:
10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

完全二叉树的性质体现的淋漓尽致,先写个函数测试是否为堆,为什么堆。再来个dfs,仅用下标就可以了,如果当前结点的左子结点下标大于n,证明该结点为叶子结点,可以输出路径了。然后依次dfs右子结点和左子结点

#include<iostream>
#include<vector>
using namespace std;
int n;
vector<int> levelOrder;
vector<int> tempPath;
bool maxHeap = true,minHeap = true;

void testHeap(){
    for(int i = 1; i <= n; i++){
        if(2*i <= n){
            if(levelOrder[2*i] > levelOrder[i]) maxHeap = false;
            if(levelOrder[2*i] < levelOrder[i]) minHeap = false;
        }
        if(2*i+1 <= n){
            if(levelOrder[2*i + 1] > levelOrder[i]) maxHeap = false;
            if(levelOrder[2*i + 1] < levelOrder[i]) minHeap = false;
        }
    }
}

void dfs(int index){
    //递归结束条件:如果该点的左右子结点均在数组中越界(只要左子结点越界即可),证明该结点为叶子结点,传入的是结点下标
    tempPath.push_back(levelOrder[index]);
    if(index * 2 > n){
        for(int i = 0; i < tempPath.size(); i++){
            if(i!=0) cout<<" ";
            cout<<tempPath[i];
        }
        cout<<endl;
        tempPath.pop_back();
        return;
    }
    if(index*2+1 <= n)dfs(index*2+1);
    if(index*2 <= n)dfs(index*2);
    tempPath.pop_back();
    return;
}

int main(){
    cin>>n;
    levelOrder.resize(n+2);
    for(int i = 1; i <= n; i++){
        cin>>levelOrder[i];
    }
    testHeap();
    dfs(1);
    if(maxHeap) cout<<"Max Heap";
    else if(minHeap) cout<<"Min Heap";
    else cout<<"Not Heap";
    return 0;
}

dfs里面要不就在递归式之前加上限制条件,不访问越界的结点,要不就加上递归边界,当前结点大于n就返回,递归边界在push_back之前

//先来个testHeap,再来个dfs,判断叶子结点,就是左右子结点的值都越界即可
#include<iostream>
#include<vector>
using namespace std;
int n;
vector<int> levelOrder;
vector<int> tempPath;

void testHeap(){
    int minHeap = true,maxHeap = true;
    for(int i = 1; i <= n; i++){
        if(i*2 <= n){
            if(levelOrder[i*2] < levelOrder[i]){
                minHeap = false;
            }
            else if(levelOrder[i*2] > levelOrder[i]){
                maxHeap = false;
            }
        }
        if(i*2+1<=n){
            if(levelOrder[i*2+1] < levelOrder[i]){
                minHeap = false;
            }
            else if(levelOrder[i*2+1] < levelOrder[i]){
                maxHeap = false;
            }
        }
    }
    if(!maxHeap && !minHeap) cout<<"Not Heap";
    else if(maxHeap) cout<<"Max Heap";
    else cout<<"Min Heap";
}

void dfs(int v){
    tempPath.push_back(levelOrder[v]);
    if(v*2>n){//只要左子结点都大于n了,证明这就是个叶子结点
        for(int i = 0; i < tempPath.size(); i++){
            if(i!=0) cout<<" ";
            cout<<tempPath[i];
        }
        cout<<endl;
        tempPath.pop_back();
        return;
    }
    if(v*2+1 <=n) dfs(v*2+1);
    if(v*2 <= n) dfs(v*2);
    tempPath.pop_back();
}

int main(){
    cin>>n;
    levelOrder.resize(n+2);//记得第一个结点是从1开始的
    for(int i = 1; i <= n; i++){
        cin>>levelOrder[i];
    }
    dfs(1);
    
    testHeap();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值