Y2K Accounting Bug

Y2K Accounting Bug

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input
Input is a sequence of lines, each containing two positive integers s and d.
Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input
59 237
375 743
200000 849694
2500000 8000000
Sample Output
116
28
300612
Deficit
题意:有一家公司,五个月发布一次账单,账单为亏损,然后告诉你月盈利和月亏损,求最大年盈利。若亏损,输出Deficit
题解:贪心,要想最大年盈利,则亏损的月要足够少,由于每五个月发布的账单都为亏损,所以根据这点,分为五种情况,每五个月亏损一个月,每五个月亏损两个月,每五个月亏损三个月…

#include<iostream>
#include<algorithm>
#include<string>
#include<map>
#include<cstring>
#include<vector>
using namespace std;

int main()
{
	int x, y;
	while (cin >> x >> y)
	{
		int ans = 0;
		if (x * 4 - y < 0) ans = x * 10 - 2 * y;
		else if (x * 3 - 2 * y < 0) ans = x * 8 - 4 * y;
		else if (x * 2 - 3 * y < 0) ans = x * 6 - y * 6;
		else if (x - 4 * y < 0) ans = x * 3 - y * 9;
		else ans = -12 * y;
		if (ans >= 0) cout << ans << endl;
		else cout << "Deficit" << endl;
	}
	return 0;
}
  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Ja_King_ZH

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值