HDU BestCoder 1001

BestCoder Sequence


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
Mr Potato is a coder. Mr Potato is the BestCoder. One night, an amazing sequence appeared in his dream. Length of this sequence is odd, the median number is M, and he named this sequence as Bestcoder Sequence. As the best coder, Mr potato has strong curiosity, he wonder the number of consecutive sub-sequences which are bestcoder sequences in a given permutation of 1 ~ N.
 
Input
  
  
Input contains multiple test cases. For each test case, there is a pair of integers N and M in the first line, and an permutation of 1 ~ N in the second line. [Technical Specification] 1. 1 <= N <= 40000 2. 1 <= M <= N
 
Output
  
  
For each case, you should output the number of consecutive sub-sequences which are the Bestcoder Sequences.
 
Sample Input
  
  
1 1 1 5 3 4 5 3 2 1
 
Sample Output
  
  
1 3
Hint
For the second case, {3},{5,3,2},{4,5,3,2,1} are Bestcoder Sequence.
下面是我的提交代码,改了三次,用了我觉得最快的算法了,但还是超时了
#include <stdio.h>
#define loop(i, n) for(int i=0; i<n; ++i)

int p[40000];
int b[40000];
int s[40000];

int main()
{
	int n, m, index, ans;
	while(1)
	{
		if(scanf("%d%d",&n,&m) != 2) break;
		loop(i, n)
		{
			scanf("%d",&p[i]);
			if(p[i] == m) index = i;
		}
		
		b[index] = s[index] = 0;
		for(int i=index-1; i>=0; --i)
		{
			if(p[i] > m) 
			{
				b[i] = b[i+1] + 1;
				s[i] = s[i+1];
			}
			else
			{
				s[i] = s[i+1] + 1;
				b[i] = b[i+1];
			}
		}
		for(int i=index+1; i<n; ++i)
		{
			if(p[i] > m)
			{
				b[i] = b[i-1] + 1;
				s[i] = s[i-1];
			}
			else
			{
				s[i] = s[i-1] + 1;
				b[i] = b[i-1];
			}
		}
		ans = 0;
		for(int beg=index; beg>=0; --beg)
		{
			for(int end=index; end<n; ++end)
			{
				if((end-beg)%2==1) continue;
				else if(b[beg]+b[end] == s[beg]+s[end]) ++ans;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


无语死,待会看一下别人是怎么个快法吧!!!
我自己是从M的两端扩展,记录比M大和小的个数,然后再枚举所有包含M的子序列,判断是否符合M是序列的中位数的条件(就是M两边比它大的总数是否和M两边比它小的总数相等),如果是的话,就++ans;
这样最后就算出来啦~然后就超时啦!
哈哈啊~~痛呀,不过第一道还是1A了,挺开心的,因为上一轮,我连一道都没过,这次进步了!加油!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值