FZU - 2150 Fire Game

该博客介绍了如何解决一个关于火在二维棋盘上蔓延的特殊游戏问题。玩家需要找到最佳策略,在有限的步数内使所有草地着火。作者提供了一个C++程序来通过广度优先搜索算法寻找最小着火时间,但未给出实际的运行平台。博客内容涉及算法设计和实现。
摘要由CSDN通过智能技术生成

FZU - 2150 Fire Game

题目

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.

.#.
3 3
.#.
#.#
.#.
3 3

#.#

3 3

…#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

题解

这题VJ爬取失败了,写了但是没地方交,hhhhh

/*************************************************************************
    > Problem: FZU - 2150 Fire Game
    > Author: ALizen_
    > Mail: hhu_zyh@qq.com
    > Blog: https://blog.csdn.net/Jame_19?spm=1001.2101.3001.5343
*************************************************************************/
#include<set>
#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define re register int
#define sf(x) scanf("%d",&x)
#define pf(x) printf("%d\n",x)
#define slf(x) scanf("%lld",&x)
#define plf(x) printf("%lld\n",x)
#define MEM(a,b) memset((a),(b),sizeof(a))
#define ref(i,a,b) for(re i = a ; i >= b ; -- i)
#define fer(i,a,b) for(re i = a ; i <= b ; ++ i)
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
char mp[20][20];
int book[20][20];
int dx[]={1,-1,0,0};
int dy[]={0,0,-1,1};
int n,m;
struct node{
    int x,y,s;
}no[110];

int bfs(node no1,node no2)   
{
    queue<node>q;
    node now,next;
    int x,y;
    q.push(no1);
    q.push(no2);
    book[no1.x][no1.y]=book[no2.x][no2.y]=1;
    while(q.size())
    {
        now=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            next.x=x=now.x+dx[i];
            next.y=y=now.y+dy[i];
            if (x >= 0 && x < n && y >= 0 && y < m && mp[x][y] == '#' && !book[x][y])
            {
                next.s=now.s+1;
                book[x][y]=1;
                q.push(next);
            }
        }
    }
    return now.s;
}

int judge()  
{
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
            if(!book[i][j]&&mp[i][j]=='#')
                return 0;
    return 1;
 } 

int main()
{
    int T,t=1,ans,cnt,k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        int k=0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",mp[i]);
            for(int j=0;j<m;j++)
            {
                if(mp[i][j]=='#')
                {
                    no[k].x=i;
                    no[k].y=j;
                    no[k++].s=0;
                }
            }
        }

        //int cnt;
        ans=inf;
        for(int i=0;i<k;i++)
            for(int j=i;j<k;j++)
            {
                memset(book,0,sizeof(book));
                cnt=bfs(no[i],no[j]);
                if(cnt<ans&&judge())
                    ans=cnt;
            }

        if(ans==inf) printf("Case %d: -1\n",t++);
        else printf("Case %d: %d\n",t++,ans);   

    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值