poj3984 迷宫问题

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

#include <iostream>
#include <cstring>
#include <queue>
#include <vector>
using namespace std;
const int maxn=10;
int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
int maza[maxn][maxn];
struct node
{
	int x;
	int y;
}befo[maxn][maxn];
void print(node a)
{
	vector<node>nodes;
	for(;;){
		nodes.push_back(a);
		if(a.x==0&&a.y==0)break;
		a=befo[a.x][a.y];
	}
	for(int i=nodes.size()-1;i>=0;i--){
		cout<<"("<<nodes[i].x<<", "<<nodes[i].y<<")"<<endl;
	}
}
void bfs()
{
	queue<node> q;
	node pre, nxt;
	pre.x=0,pre.y=0;
	q.push(pre);
	while(!q.empty()){
		pre=q.front();
		
		if(pre.x==4&&pre.y==4){
			print(pre);
			return ;
		}
		for(int i=0;i<5;i++){
			int tempx=pre.x+dir[i][0];
			int tempy=pre.y+dir[i][1];
			if(tempx>=0&&tempx<=4&&tempy>=0&&tempy<=4&&maza[tempx][tempy]==0){
				nxt.x=tempx;
				nxt.y=tempy;
				q.push(nxt);
				befo[tempx][tempy]=pre;
			}
		}
		q.pop();
	}
}
int main()
{
	ios::sync_with_stdio(false);
	for(int i=0;i<5;i++)
	for(int j=0;j<5;j++)cin>>maza[i][j];
	bfs();
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值