hdoj 1162 Eddy's picture

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

Sample Input

  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output

  
  
3.41
 

解题思路:

这道题也属于模板题吧,关键怎么把它转化为模板的问题,我是通过用变量来记录每个点的,例如(1.0,1.0)用i=1来记录,(2.0,2.0)用j=2来记录,然后把它们的距离记作权值,套入模板就解决了。


#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
double x[110],y[110],sum;
int per[110],n;
struct node
{
	int u,v;
	double w;
}edg[10000];
bool cmp(node a,node b)
{
	return a.w<b.w;
}
double dis(int i,int j)
{
	return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
void init()
{
	for(int i=1;i<=n;i++)
		per[i]=i;
}
int find(int x)
{
	int r=x;
	while(r!=per[r])
		r=per[r];
	return r;
}
bool join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fy]=fx;
		return true;	
	}
	return false;
}
int main()
{
	int i,j,k;
	while(scanf("%d",&n)!=EOF)
	{
		init();
		k=1;
		for(i=1;i<=n;i++)
			scanf("%lf%lf",&x[i],&y[i]);
		for(i=1;i<=n;i++)
			for(j=i+1;j<=n;j++)
			{
				edg[k].u=i;
				edg[k].v=j;
				edg[k].w=dis(i,j);
				k++;
			}
		sort(edg+1,edg+k,cmp);
		for(i=1,sum=0;i<=k-1;i++)
		{
			if(join(edg[i].u,edg[i].v))
				sum+=edg[i].w;
		}
		printf("%.2lf\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值